4

i am unable to visualise many 3d graphics of different applications [ex:-biodigital human 3d of chrome store] and many more 3d games and graphics i am current using Gallium 0.4 on AMD RS780 as my graphic card and do not know whether it is functioning or not in ubuntu but in windows 7 it works so can any body suggest stepwise settings or sequence of commands to get it fixedenter image description here

enter image description here this screenshot shows a 3d app which is been supported in windows 7 installed through virtuaal box but the same thing i am unable to get it done in ubuntu

and this is shown when i type the command in terminal to know about my graphics card enter image description here enter image description here

*edit enter image description here

  • 1
    Your card is an integrated Radeon HD3000 series. It is no longer supported by the proprietary AMD Catalyst drivers but it should work with the open source drivers. Most likely you do not get hardware support for WebGL because Chrome disables it by default. See How To Enable WebGL In Chrome On Ubuntu? – bain May 30 '14 at 14:43
  • 1
    You can not install the drivers from AMD web site on your computer. It is not possible because AMD do not support your graphics card any more. It is too old. You will have to use the open source drivers. Please read Radeon HD 2000, 3000, 4000 on Ubuntu 12.10 and higher: fglrx (legacy) unsupported, what to do? To enable WebGL for Chrome see How To Enable WebGL In Chrome On Ubuntu? – bain May 31 '14 at 9:55
  • 1
    Check glxinfo|grep 'OpenGL vendor' – bain May 31 '14 at 11:50
  • 1
    Try glxinfo|grep -E 'OpenGL|direct' and cat /var/log/Xorg.0.log - post the output to pastebin.com and link here. It is easier to copy and paste text than to take screenshots. – bain May 31 '14 at 14:02
  • 1
    It looks like you are using the open source drivers and have full accelerated 3D (Direct rendering: Yes). Why do you think it is not working? – bain May 31 '14 at 14:41
9

Sometimes Google Chrome blocks 3D support in their browser in Linux due to known driver issues for example. However, there is a way to override this and force 3D support in Chrome.

To do this, navigate to chrome://flags in your browser. In there, search for the option Ignore GPU blacklist and enable it. After that you need to restart your browser to apply the changes.

  • Doesn't seem to work with Chrome 40. – Yanick Rochon Feb 7 '15 at 14:31
  • 1
    Worked for Chrome 48.0.2564.82 (64-bit) on Linux Mint 17.3 / Ubuntu 14.04 – Raffael Jan 27 '16 at 21:19
  • Works on Chrome 58 on Ubuntu 14.04 (64 bit) – gregoiregentil Apr 24 '17 at 3:28
0

In Chrome 60 there is no Ignore GPU blacklist, but it is Override software rendering list now (the first line in chrome://flags)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.