It is one more attempt to get Fn keys to volume up/down, brightness, etc. working. Those controls are simply not working in my non-branded ultrabook.

I want to detect them to modify /home/username/.config/openbox/lubuntu-rc.xml, as the following doesn't seem working:

<keybind key="XF86AudioRaiseVolume">
    <action name="Execute">
        <command>amixer -q sset Master 3%+ unmute</command>

Neither xev nor xbindkeys nor keytouch are detecting when I press volumen up or brightness down, for example. The start/stop touchpad button is working, but is not detected by those applications either.

I also tried with dconf-editor as it is suggested here. next was already set to XF86AudioNext (and it is active)

Here, I read the following explanation:

Some laptop Fn key combinations are multimedia keys (appearing to the OS as ordinary keys with nonstandard codes), while others trigger ACPI events that eventually reach the OS, and some are just handled by the BIOS and never seen by the OS. The information paths are explained on the Hotkeys/Architecture page on the Ubuntu wiki, complete with diagrams.

If the OS can't see anything when you press the brightness keys, it could be because they're handled directly by the BIOS. The battle is not completely lost — it is in principle possible to hack the BIOS — but the difficulty level is considerably raised.

Any idea?

  • 1
    What kind of keyboard is it? It is possible that your keyboard has some keys that use keycodes > 255, in which case they are not supported by Xorg, see freedesktop bug #11227. It is a long standing problem that won't be fixed until the world leaves Xorg behind.
    – bain
    May 27, 2014 at 21:18
  • 1
    xev doesn't report the keycodes for your keypresses, but does the kernel see the scancodes? You should be able to check dmesg output and see messages like Unknown key pressed (translated set 2, code 0xa0 on isa0060/serio0 - alternately you might try sudo showkey --scancodes
    – James S.
    May 30, 2014 at 19:41
  • 1
    @bain, the keyboard is a US Keyboard. I have set it to Spanish though. Lubuntu has set the keyboard model to pc105 by default. On the oher hand, I don't understand the topic of that link well: isn't it possible to use XI2 instead Xorg? But firstly, how could we know if the keyboard uses keycodes > 255?
    – chelder
    May 31, 2014 at 16:52
  • 1
    @JamesS., showkey has the same result than xev, xbindkeys or keytouch. I typed dmesg | grep -i 'key', dmesg | grep -i 'translated', etc: the result is empty.
    – chelder
    May 31, 2014 at 17:10
  • 2
    Switch to the console with ctrl-alt-f1 and hit the key. See the instructions at Ubuntu wiki MultimediaKeys.
    – bain
    May 31, 2014 at 18:32

1 Answer 1


You may need acpi support

sudo apt-get install acpi acpi-support acpica-tools acpid acpidump acpitail acpitool libacpi0 laptop-detect pommed

Beyond installing the above packages, I finally fixed this issue on my laptop by uninstalling the toshet package after discovering my specific model was not compatible or supported by the toshet application. I doubt you have toshet installed but you can check to see by typing the following command:

dpkg -l | grep toshet

There should be no output if toshet is not installed. If it is listed in the subsequent output of that command, you can uninstall it by typing the following:

sudo apt-get purge toshet 
  • 1
    I copied and pasted that code. It has been installed. Unfortunately, the keys are not working yet. Note: during the installation I read the following text: Starting Apple laptops hotkeys events handler: invoke-rc.d: initscript pommed, action "start" failed
    – chelder
    Aug 3, 2014 at 21:14
  • 1
    @chelder I wouldn't worry about the apple stuff if you're not using an apple it doesn't matter anyway. The only reason I included it was because I'm not really sure package I installed to enable the support I have. I do know that my fn keys did not work after the initial 14.04 installation. The confusion is because I actually fixed the issue by uninstalling toshet. After reviewing the docks I discovered my model was not listed as a supported laptop. I'll try to see if there is maybe something else that I installed to fix the issue.
    – mchid
    Aug 4, 2014 at 19:24
  • 1
    Well, I have uninstalled toshet. It is not working yet. Thanks for your help!
    – chelder
    Aug 4, 2014 at 22:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .