8

I have been trying to use Gnome 3.8 / 3.10 / 3.12 since Ubuntu Gnome 13.10 and no matter what I do it changes the screen resolution to 720p, instead of 1080p, so I have to manually set 1080p every time I start the PC!

Card: Nvidia GTX 550 Driver: all available Distro: Ubuntu 13.10 / 14.04 Gnome Shell: 3.8 / 3.10 / 3.12

Things I tried so far:

  • opening nvidia-settings as root and user
  • changing settings in nvidia-settings= force Powermizer to Maximum / OpenGL settings / Quality Settings - (I have done it all)
  • forcing nvidia-settings to load on startup (Startup Aplications)
  • adding/deleting/changing xorg.conf = "modes" / "metamodes" / "Display" / "EDID" - (I have done it all)
  • adding gdm/init = xrandr output DVI-D-0 --mode
  • installing different Kernels = 3.10 / 3.12 / 3.13 / 3.14
  • installing different Nvidia Drivers= all available for Ubuntu
  • installing Lightdm/MDM = everything breaks down
  • changing cables = DVI / HDMI
  • blocking/changing EDID = blocking the extensions on EDID (maybe the hdmi sound was causing the problem) / "noEDID"- system looses all resolutions

What I learned so far:

  • Whenever I try to force 1080p by adding a command to xorg/gdm/xrandr the screen changes to 1080p for 1sec and then goes back to 720p! ... : (
  • Tested Xubuntu/Kubuntu 14.04 = no resolution problems, just the usual terrible Nvidia performance (no vsync, no vdpau)
  • Just installed Linux Mint yesterday and this problem doesn't happen (MDM), 1080p since the login screen.
  • Tested Gnome 3.10/3.12 on the latest Fedora / Suse / Antergos and the problem persists!

Possible causes:

  • Xserver 3.15 / 3.13 = I tried to replace ubuntu 14.04 xserver (3.15) with ubuntu 12.02 (3.13) cheating the repos and the whole system melted down!

  • I really want Gnome 3 and a supported version of Ubuntu (I am stuck at 13.04)!

  • I am very persistent and have problems taking NO for an answer!
  • I had an ATI HD 4x series and I saved money to buy this Nvidia because gaming on Linux became impossible (missing GL extensions on Legacy drivers)... so .... thinking that it would solve all the video issues I had on Linux with ATI ... but ... how wrong was I ???? Now I have problems with basic functionalities (RESOLUTION / VSYNC / VDPAU) !

....I started using Linux 3 years ago and all these GPUs mess have been a nightmare in my Linux experience! ....It's what makes me think about giving up Linux for all!

5

You did not specify whether you saved your settings to the X configuration file (/etc/X11/xorg.conf) using nvidia-settings. That should solve this. Just open nvidia-settings as root:

sudo nvidia-settings

Then, choose the right settings and click on the "Save to X Configuration" button:

enter image description here


If this does not work, there is something else overwriting your settings. Probably your desktop environment. As a workaround, you can use this script:

#!/bin/bash

sleep 10
xrandr --output DVI-D-0 --mode 1920x1080 
echo "Script was run" 

The sleep is needed to make sure that the Desktop Environment has finished starting before the script is run. That way, you know that it will be run after the DE has reconfigured your screens. Make the script executable and add it to your startup applications. That should do the trick.

  • @user282534 OK, in that case it sounds like something is overwriting your settings. Presumably the Gnome Display settings thingie. Did you have a look at the answer I linked to? A possible workaround would be to write a script that uses xrandr to set your desired settings and add that script to your session startup files. I'd be happy to write the script for you if you add the output of xrandr (once you have chosen the right settings) to your question. – terdon May 19 '14 at 14:00
  • Hi terdon, first of all thanks for answering... 1 ° - I did click on the "Save to X Configuration" button many times, running nvidia-settings as SUDO, as GKSUDO, editing xorg.conf manually as root.... | 2° - Xrandr lists all resolutions available, including 1920x1080, but the one marked as "preferred" is 12080x720 | 3° - When I log in the screen flashes on 1080p (after tweaking xorg.conf / gdm init.conf, xprofile, monitors.xml) and goes back to 720p. – Raphael Sanches May 19 '14 at 14:05
  • 1
    @user282534 yes, I know. Creating a script that runs the right xrandr command should fix this. It ain't elegant but it should work. Please edit your question and add the output of xrandr after setting the desired resolution and I will write a script for you that calls the right command. The flashing is because you have the desired resolution set (presumably in xorg.conf) but Gnome in its infinite wisdom is then overwriting it. – terdon May 19 '14 at 14:09
  • Hi terdon,..... 1° - I did try to use a script forcing xrandr to output 1080p and add it to the Startup Aplications... and it does at one point, but then something bypass all that and sets the screen to 720p.... Is there more modules involved on this besides GDM / X11 /Nvidia? | 2° - Is it possible that there is a command on GDM forcing the EDID "preferred" mode no matter what? – Raphael Sanches May 19 '14 at 14:12
  • @user282534 1) did you add it to GDM's startup applications or yours? 2) Try adding sleep 10 to your script, before the xrandr command. That will cause it to wait 10 seconds before running it. Assuming something else is re-setting the resolution after you login, adding the delay should cause the script to be run afterwards and avoid the problem. 3) Yes, Gnome is also involved, I'm pretty sure that's what's causing you pain. Have you actually tried setting the resolution through gnome's settings instead of nvidia-settings? – terdon May 19 '14 at 14:14
0

I had the same problem. While using Optimus Manager (alternative to NVIDIA Prime), i was playing a game normally. I changed some in-game graphic settings and it crashed, due to which i had to reboot linux and then the resolution changed as soon i logged in ( after the login screen). I spend endless time fixing it using xrandr and other stuffs but failed. I later found out nvidia-settings and optimus-manager generates its own xorg.conf.

So a quick and efficient solution was very simple and was as follows:

Delete:

/etc/X11/xorg.conf

Delete unnecessary configuration files:

/etc/X11/xorg.conf.d/

e.g:

10-optimus-manager.conf

I then rebooted and all became back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.