3

I have installed Microsoft Office Home and Student 2010 through PlayOnLinux (v 4.2.2) onto my Ubuntu 14.04 distribution. Icons were created on my desktop for Word and Excel. If I click on either icon, I get into the application and create a file without any problems. However, when I click on a .xlsx or .docx file, Libre Office opens rather than Excel or Word.

I have Googled, searched and tried all solutions found and none bring up Word or Excel when I click a .xlsx or docx file. Is there currently a new solution to this problem or some new ideas to try? I am very new to Linux so please go easy on me.


Hello Mitch and thank you for the reply.

There are a few things different between what you see and what I see.

On your first screen you have options "Resize Icon" and "Restore Icon's Original size." I do not have these two options. Although this does not matter, I'm just pointing out the difference.

On you second screen shot, I do not have Microsoft Word as an option. Also, near the bottom, I do not have the second line from the bottom which on your screen has Reset, Add, and Set As Default. My last line is the same as yours, Help (on left) and Close (on right).

Could there be some sort of version differences between our programs? I installed using PlayOnLinux. I did not install Wine but I noticed that PlayOnLinux did durring the installation. Anything I can specifically check for or change?

3

Right Click on the .docx or .xlsx, click on Properties. Once the new window opens click on the Open With Tab, (in this example, its a .docx document) and choose, Microsoft Word.

Click on set as default, and thats it.

enter image description here

enter image description here

Since I'm experimenting with both Wine, and PlayOnLinux, here is another explanation for PlayOnLinux:

Open up PlayOnLinux, and click on Settings --> File associations. Once the new window opens, make sure that .docx is associated with Word, otherwise; create a new association.

enter image description here

enter image description here

1

See my answer to a similar question. Basically:

cp ~/Desktop/Microsoft\ *.desktop ~/.local/share/applications/

protected by Community Sep 12 '14 at 16:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.