18

My Lenovo Z570 has two GPU's, nVidia and Intell. Brightness control has no effect what so ever over the screen brightness, and because I've had some major issues in the past when I was trying to fiddle with nVidia drivers and settings, and I wanna be cautious now. I haven't find similar questions referring 14.04 LTS with similar configuration as mine.

I've read that it could be fixed by adding/changing content in xorg.conf but when I run

sudo gedit /etc/X11/xorg.conf

the file comes out to be absolutely empty. What do I need to do, what do I need to add to it and not get my laptop screwed with a black screen again?

  • this solved my problem : askubuntu.com/a/450690/313731 – Arash Aug 8 '14 at 15:47
  • What is the model of your card? – Braiam Oct 20 '14 at 13:04
  • nVidia 525M and Intell Integrated HD Graphics 3000 – Valentin Oct 21 '14 at 17:54
  • The solution of @SPRBRN worked on my Lenovo Thinkpad X250 with Intel Graphics and Ubuntu 14.04 – leonard vertighel Jan 5 '16 at 15:45
19

For those of you having this problem with an Intel card, look at this fix:

You can see whether you use an Intel card with the following command. If you see "intel_backlight", you probably have an Intel card.

ls /sys/class/backlight/

If so, execute the following command:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

You may check first if that file exists, but touching it won't do any harm. Then edit the file:

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Insert the following code:

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection

Save the file, log out, log back in. This worked for me on Ubuntu 14.04, and it should work on 13.10 as well.

Credits to It's FOSS

  • Here's what I got after doing that: (gedit:3465): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files I do have a secondary Intel GPU. – Valentin Aug 12 '14 at 16:58
  • 1
    @SPRBRN: Worked for me. Vostro 1500, just installed Intel driver (to prevent crashes) - boom, 0% backlight == very dim screen. I confirmed with the intel_backlight directory, there was 'actual_brightness' (or some such) in there that had a value of 00. Once I installed your fix, it jumped way up (256,512 or so). Thanks for sharing! – The Dude Sep 12 '14 at 17:28
  • 2
    If it happens that you see intel_backlight, you change/add 20-intel.conf but the system will not boot to graphics, you can delete the file in recovery mode (wiki.ubuntu.com/RecoveryMode). – wenzeslaus Oct 22 '14 at 1:28
  • This worked for me with Xubuntu 14.10 on a ThinkPad T520 (the problem only occurred after I set up Bumblebee), but for some reason it made Xfce's Whisker Menu stop working. I ended up just removing the Whisker Menu panel item, but it would be nice to have a fix for that as well. – srunni Nov 21 '14 at 15:12
  • Your solution worked on my Lenovo Thinkpad X250 with Intel Graphics and Ubuntu 14.04 – leonard vertighel Jan 5 '16 at 15:47
12

This worked for my Lenovo T530 with Nvidia/Intel...

Note. My BIOS graphics settings were changed from Nvidia Optimus to Discrete Graphics (this was so I can drive a 4K external monitor from the Display Port). Also no need to have the file /etc/X11/xorg.conf on your system. The following assumes you are running the Nvidia driver and have access to the NVIDIA X Server Settings app in Unity.

First, bring up the text editor and I'll show you how to add the right contents to this file for your graphics card.

gksu gedit /usr/share/X11/xorg.conf.d/20-nvidia.conf

If your file is empty as mine was then open up the app "NVIDIA X Server Settings" from Unity.

Then go to the "X Server Display Configuration" section.

At the bottom of the screen click the button "Save to X Configuration". We don't want to actually save anything here, but click on the "Show Preview" button.

Scroll through until you see Section "Device" and the following EndSection. Highlight and copy the entire section. Mine looked like this:

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   BoardName      "NVS 5400M"
EndSection

Paste this into the /usr/share/X11/xorg.conf.d/20-nvidia.conf file opened before.

Now paste the following line just before the EndSection

Option        "RegistryDwords" "EnableBrightnessControl=1"

It should look like this:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVS 5400M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Now save and close /usr/share/X11/xorg.conf.d/20-nvidia.conf and reboot. My brightness control now works. Got the idea from this related post.

  • 1
    Works perfectly on my Lenovo W520. Thanks for this clear description! – tlwhitec Feb 8 '15 at 11:41
  • 1
    Nice and easy solution if using NVIdia drivers. Used on Lenovo W510, work perfectly. – sir_k Mar 19 '15 at 11:59
  • Works fine with my Thinkpad T430 and Discrete Graphics enabled in BIOS. – fnkr May 4 '16 at 16:15
  • Still valid, excellent answer. – Karol Nowak Jun 16 '16 at 21:29
  • There is a trick, Nvidia X Server Settings have no data in the preview and somehow does not save to a visible file. BUT I saved the configuration twice and it created a backup file. From that file I was able to pick up the Section "Device part. – visoft Aug 22 '16 at 20:02
0

Run sudo nvidia-xconfig to generate the xorg.conf file.

I am having the same issue, however even after setting the DWord in xorg.conf the brightness is not changing.

0

Is it that the brightness control doesn't persist or is it that modifying it has no effect?

I have had issues where changing brightness control didn't persist across reboots. I have a Dell XPS L502X with an integrated Intel and a GeForce GT 540M graphics card. I use xbacklight to overcome the problem. Install the package with

sudo apt-get install xbacklight

and use the following command to set the brightness, say

xbacklight -set 20%

If you want to automate this, you can add this to "Startup Applications", so that every time your computer starts, the brightness would be set to 20%.

  • Does not help unfortunately :( – Valentin May 29 '14 at 18:13

protected by Community Sep 27 '14 at 21:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.