4

I just upgraded my System to 14.04.

After restarting when the update was finished I did not see any menu bars or panels.

Right clicking and opening a terminal via ctrl+alt+t is not possible. However I can access the terminal via alt+F1. I already tried out installing the unity-desktop again but it didn't change anything .

Do you have any suggestions?

  • 1
    did you try to reinstall ubuntu-desktop? Because you mentioned you were trying to reinstall unity-desktop there's no package unity-desktop do sudo install --reinstall ubuntu-desktop and tell if it does anything. – JoKeR May 17 '14 at 14:21
  • Thanks for your answer! Unfortunately this didn't change anything. Could there by a problem with nvidia? – Dominik B. May 17 '14 at 14:30
  • 1
    please tell me the output of lspci -nnk | grep -iA2 VGA – JoKeR May 17 '14 at 14:32
  • or just what graphics cards + drivers u have, you can use paste.ubuntu.com for long terminal output - you can also use lshw or lshw-gtk to get the info – Wilf May 17 '14 at 14:40
  • 1
    askubuntu.com/questions/17381/… This may be relevant to you, – Chris Carter May 17 '14 at 14:41
7

I tried reproducing your trouble by disabling Unity-plugin, after this resetting Unity or its settings didn't work. So, this what I've done trying to get it back:

install Compiz Config Settings Manager if you don't have it:

sudo apt-get install compizconfig-settings-manager

Now, you have to go to Compiz Config Settings Manager and enable Unity-plugin when Compiz manager opened navigate to Unity-plugin or just type in search Unity then click on it and on the left put a tick wait a sec it should get back.

How to get to Compiz Manager and Terminal without Unity interface when nothing's responding even pressing Ctrl+Alt+T ? There's always the way to get around, for example press Ctrl+Alt+Del you'll get System Monitor navigate to File Systems you'll get listed with your HDD subsections and simply click twice on Home section now you should get Nautilus running. Navigate to / and hit the search bar just type Terminal now you can launch Terminal from search result, the same way type CompizConfig and you should get Compiz Manager launcher.

What other ways you can try using Terminal try to purge Unity:

sudo apt-get remove --purge unity

Now reinstall it along with ubuntu-desktop simply type and run:

sudo apt-get update

sudo apt-get install --reinstall ubuntu-desktop

This should automatically install and put Unity back on, you'll be able to see the packages that are going to be installed, if not run:

sudo apt-get install unity

After all may require reboot, didn't occur to me.

if you want or need to reset Unity on Ubuntu 14.04 you can use Unity Tweak Tool to do so, if you don't have it installed:

sudo apt-get install unity-tweak-tool

and to reset run:

unity-tweak-tool --reset-unity

Alternatives, all this stuff I wrote should definately work if everything else is fine including video drivers and you can try it in addition with Gnome for example, simply install gnome-shell:

sudo apt-get install gnome-shell

now reboot, and then at the login screen choose gnome-shell and log in, if everything is ok, it should work 100%, if not, the problem is not only in Unity, it might refer to video drivers issues as well.

These are all ways that I could figure out, so good luck!

  • Thank you very much for your help! Everything went well until sudo apt-get install unity. I restarted my computer and nothing changed. So I was trying to install the unity-tweak-tool. But as I was trying that I got an error. It says: You might want to run `apt-get -f install' to correct these: The following packages have unmet dependencies: libeoffice-core: Depends: libreoffice-common ( > 1:4.2.3~rc3) but it is not going to be installed libreoffice-ogltrans: Depends:libreoffice-commin but it is not going to be installed. E: Unmet dependencies. Try 'apt-get -f install'. – Dominik B. May 18 '14 at 7:43
  • I tryed that line an some things were installed but after that I got the same error message as I was trying to install the unity-tweak-tool again. apt-get dist-upgrade doesn't work as well and I'm not able to install gnome-shell. Do you have any idea what is going on? – Dominik B. May 18 '14 at 7:46
  • follow this askubuntu.com/questions/140246/… – JoKeR May 20 '14 at 12:48
  • 1
    Thank you ! the unity-tweak-tool approach worked for me. ahhhhh finally pulled me out of this 2-hour headache! – teddy teddy Nov 17 '14 at 21:55
  • The unity-tweak-tool worked for me too. Thanks – user568109 Sep 16 '15 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.