0

LibreOffice help recommends me to install a higher version of LibreOffice than I can get from the Ubuntu Software Center. I can do it by direct installing from *.deb files. I know most of required system properties, their versions are much higher than required. I hope that it applies also for the other ones, but the lower LibreOffice version in the Ubuntu Software Center may be due to such a discrepancy. If it is so, please answer this long question summarily.

For installing I need to see if my Ubuntu 12.04 system has

  • gtk version 2.10.4 or higher [According to How to know my GTK version? I have got
    user@CPU:~$ dpkg --get-selections | grep gtk
    adobe-flash-properties-gtk   install
    appmenu-gtk                  install
    appmenu-gtk3                 install
    apport-gtk                   install
    bzr-gtk                      install
    gir1.2-dbusmenu-gtk-0.4      install
    gir1.2-gtk-2.0               install
    gir1.2-gtk-3.0               install
    gir1.2-gtksource-3.0         install
    gir1.2-javascriptcoregtk-3.0 install
    gtk2-engines                 install
    gtk2-engines-murrine         install
    gtk3-engines-unico           install
    ibus-gtk                     install
    ibus-gtk3                    install
    jockey-gtk                   install
    libavahi-ui-gtk3-0           install
    libcanberra-gtk-module       install
    libcanberra-gtk0             install
    libcanberra-gtk3-0           install
    libcanberra-gtk3-module      install
    libdbusmenu-gtk3-4           install
    libdbusmenu-gtk4             install
    libgdu-gtk0                  install
    libgtk-3-0                   install
    libgtk-3-bin                 install
    libgtk-3-common              install
    libgtk2-perl                 install
    libgtk2.0-0                  install
    libgtk2.0-bin                install
    libgtk2.0-common             install
    libgtkhtml-4.0-0             install
    libgtkhtml-4.0-common        install
    libgtkhtml-editor-4.0-0      install
    libgtkmm-2.4-1c2a            install
    libgtkmm-3.0-1               install
    libgtksourceview-3.0-0       install
    libgtksourceview-3.0-common  install
    libgtkspell-3-0              install
    libgwibber-gtk2              install
    libindicate-gtk3             install
    libjavascriptcoregtk-1.0-0   install
    libjavascriptcoregtk-3.0-0   install
    libnm-gtk-common             install
    libnm-gtk0                   install
    libreoffice-gtk              install
    libswt-cairo-gtk-3-jni       install
    libswt-glx-gtk-3-jni         install
    libswt-gnome-gtk-3-jni       install
    libswt-gtk-3-java            install
    libswt-gtk-3-jni             install
    libswt-webkit-gtk-3-jni      install
    libwebkitgtk-1.0-0           install
    libwebkitgtk-1.0-common      install
    libwebkitgtk-3.0-0           install
    libwebkitgtk-3.0-common      install
    libwmf0.2-7-gtk              install
    python-aptdaemon.gtk3widgets install
    python-gtk2                  install
    software-properties-gtk      install
    transmission-gtk             install
    ubuntu-sso-client-gtk        install
    usb-creator-gtk              install
    xdg-user-dirs-gtk            install
    user@CPU:~$ 
    
    ];
  • glibc2 version 2.5 or higher [

    user@CPU:~$ dpkg --get-selections | grep glibc2
    user@CPU:~$ 
    ];

  • Gnome 2.16 or higher, with the gail 1.8.6 and the at-spi 1.7 packages (required for support for assistive technology [AT] tools), or another compatible GUI (such as KDE, among others) - [by my System Monitor: GNOME 3.4.2,

    user@CPU:~$ dpkg --get-selections | grep gail
    libgail-3-0                  install
    libgail-common               install
    libgail18                    install
    user@CPU:~$
    user@CPU:~$ dpkg --get-selections | grep at-spi
    at-spi2-core                 install
    qt-at-spi                    install
    user@CPU:~$ 
    
    ]. Which of the numbers are relevant for the particular part of my system? If none, how to find the required ones? Is glibc2 relevant for the purpose?

  • 'A recent version of Java Runtime Environment (JRE). How can I find which version is installed?

    Thanks!

1 Answer 1

1

You can run dpkg -l | grep package_name to get its version. It's not always clear what the exact name is, so here are some suggestions for 12.04:

ii  libgtk2.0-0      2.24.10-0ubuntu6.1      GTK+ graphical user interface library

ii  libglib2.0-0     2.32.4-0ubuntu1         GLib library of C routines

ii  libc-bin         2.15-0ubuntu10.5        Embedded GNU C Library: Binaries

For java, please see this question.

Alternatively, just search http://packages.ubuntu.com.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.