10

On freshly installed Ubuntu 14.04, with freshly installed vlc, the vlsub extension launches a window when no file is open. Once I open any video, the extension does not open the vlsub window.

Tried with the master-daily ppa,

Tried with vlsub-extension in the ppa, &

Tried with manual install.

None of these worked Always the same issue: the vlsub window refuses to open once any video is played.

Has anyone an idea to fix it?

1
  • The command for the system wide install is not working because permission is denied so I used 'gksudo nautilus' to copy-paste the lua file manually and...finally this works! Thanks! – user293103 Jun 13 '14 at 4:31
7

According to their official website:

VLSub is not working with Vlc 2.1.x on any platform because the lua "net" module needed to interact with opensubtitles has been removed in this release for the extensions. Works with Vlc 2.2 on mac and linux.

Too bad Ubuntu has 2.1.x. So, first step is to get a more recent version of VLC:

sudo add-apt-repository ppa:videolan/master-daily
sudo apt-get update
sudo apt-get install vlc

At the time of writing, the VLSub plugin in the Ubuntu repositories (0.9.10-1) does not search for subtitles, and the latest version from GitHub has problems opening the subtitle once downloaded. So, I created a fork that actually works (tested on VLC 2.2.0~~git20140609+r57027+123~ubuntu14.04.1 and all later releases, no problems so far):

wget https://github.com/kraxor/vlsub/archive/master.zip
unzip master.zip
cd vlsub-master

To install locally, type:

cp vlsub.lua ~/.local/share/vlc/lua/extensions/

Or install system-wide:

sudo cp vlsub.lua /usr/lib/vlc/lua/extensions/

And you're done. Enjoy.

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.