-1

I was using 14.04 beta, When the stable release rolled out, I thought that it might update to stable but now i keep getting these messeges with sudo apt-get update, and a similar one with synaptic

    Ign cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty Release.gpg
    Ign cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty Release
    Err cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/main amd64 Packages
      Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    Err cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/restricted amd64 Packages
      Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    Err cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/main i386 Packages
      Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    Err cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/restricted i386 Packages
      Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    Ign cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/main Translation-en_US
    Ign cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/main Translation-en
    Ign cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/restricted Translation-en_US
    Ign cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326) trusty/restricted Translation-en
    Ign http://dl.google.com stable InRelease                                      
    Ign http://dl.google.com stable InRelease                                      
    Hit http://dl.google.com stable Release.gpg                                    
    Hit http://dl.google.com stable Release.gpg                                    
    Hit http://dl.google.com stable Release                                        
    Hit http://dl.google.com stable Release                                        
    Hit http://dl.google.com stable/main amd64 Packages                            
    Hit http://dl.google.com stable/main i386 Packages                             
    Hit http://dl.google.com stable/main amd64 Packages                            
    Hit http://dl.google.com stable/main i386 Packages                             
    Get:1 https://download.01.org trusty InRelease                                 
    Ign https://download.01.org trusty InRelease                                   
    Get:2 https://download.01.org trusty/main amd64 Packages/DiffIndex             
    Ign https://download.01.org trusty/main amd64 Packages/DiffIndex               
    Ign https://download.01.org trusty/main i386 Packages/DiffIndex                
    Ign http://dl.google.com stable/main Translation-en_US                         
    Ign http://dl.google.com stable/main Translation-en                            
    Ign http://dl.google.com stable/main Translation-en_US                         
    Ign http://dl.google.com stable/main Translation-en                            
    Ign http://archive.ubuntu.com trusty InRelease                                 
    Ign http://extras.ubuntu.com trusty InRelease                                  
    Ign http://archive.ubuntu.com trusty-updates InRelease                         
    Ign http://archive.canonical.com trusty InRelease                              
    Ign http://archive.ubuntu.com trusty-backports InRelease                       
    Hit http://extras.ubuntu.com trusty Release.gpg                                
    Hit http://archive.canonical.com trusty Release.gpg                            
    Ign http://archive.ubuntu.com trusty-security InRelease                        
    Hit http://extras.ubuntu.com trusty Release                                    
    Ign http://archive.ubuntu.com trusty-proposed InRelease                        
    Hit http://archive.canonical.com trusty Release                                
    Hit http://archive.ubuntu.com trusty Release.gpg                               
    Hit http://extras.ubuntu.com trusty/main amd64 Packages                        
    Hit http://archive.canonical.com trusty/partner amd64 Packages                 
    Hit http://archive.ubuntu.com trusty-updates Release.gpg                       
    Hit http://extras.ubuntu.com trusty/main i386 Packages                         
    Hit http://archive.ubuntu.com trusty-backports Release.gpg                     
    Hit http://archive.canonical.com trusty/partner i386 Packages                  
    Hit http://archive.ubuntu.com trusty-security Release.gpg                      
    Hit http://archive.ubuntu.com trusty-proposed Release.gpg                      
    Hit http://archive.ubuntu.com trusty Release                                   
    Hit http://archive.ubuntu.com trusty-updates Release                           
    Hit http://archive.ubuntu.com trusty-backports Release                         
    Hit http://archive.ubuntu.com trusty-security Release                          
    Hit http://archive.ubuntu.com trusty-proposed Release                          
    Hit http://archive.ubuntu.com trusty/main Sources                              
    Hit http://archive.ubuntu.com trusty/restricted Sources                        
    Hit http://archive.ubuntu.com trusty/universe Sources                          
    Hit http://archive.ubuntu.com trusty/multiverse Sources                        
    Hit http://archive.ubuntu.com trusty/main amd64 Packages                       
    Hit https://download.01.org trusty/main amd64 Packages                         
    Ign http://extras.ubuntu.com trusty/main Translation-en_US                     
    Ign http://extras.ubuntu.com trusty/main Translation-en                        
    Ign http://archive.canonical.com trusty/partner Translation-en_US              
    Hit http://archive.ubuntu.com trusty/restricted amd64 Packages                 
    Hit http://archive.ubuntu.com trusty/universe amd64 Packages
    Ign http://archive.canonical.com trusty/partner Translation-en
    Hit http://archive.ubuntu.com trusty/multiverse amd64 Packages
    Hit http://archive.ubuntu.com trusty/main i386 Packages    
    Hit https://download.01.org trusty/main i386 Packages
    Hit http://archive.ubuntu.com trusty/restricted i386 Packages
    Hit http://archive.ubuntu.com trusty/universe i386 Packages
    Hit http://archive.ubuntu.com trusty/multiverse i386 Packages
    Get:3 https://download.01.org trusty/main Translation-en_US
    Ign https://download.01.org trusty/main Translation-en_US                      
    Hit http://archive.ubuntu.com trusty/main Translation-en                       
    Ign https://download.01.org trusty/main Translation-en     
    Hit http://archive.ubuntu.com trusty/multiverse Translation-en
    Ign http://ppa.launchpad.net saucy InRelease   
    Hit http://archive.ubuntu.com trusty/restricted Translation-en
    Hit http://ppa.launchpad.net saucy Release.gpg
    Hit http://archive.ubuntu.com trusty/universe Translation-en
    Hit http://ppa.launchpad.net saucy Release
    Hit http://archive.ubuntu.com trusty-updates/main Sources
    Hit http://ppa.launchpad.net saucy/main amd64 Packages
    Hit http://archive.ubuntu.com trusty-updates/restricted Sources
    Hit http://archive.ubuntu.com trusty-updates/universe Sources
    Hit http://ppa.launchpad.net saucy/main i386 Packages
    Hit http://archive.ubuntu.com trusty-updates/multiverse Sources
    Hit http://archive.ubuntu.com trusty-updates/main amd64 Packages
    Hit http://archive.ubuntu.com trusty-updates/restricted amd64 Packages
    Hit http://archive.ubuntu.com trusty-updates/universe amd64 Packages
    Hit http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages
    Hit http://archive.ubuntu.com trusty-updates/main i386 Packages
    Hit http://archive.ubuntu.com trusty-updates/restricted i386 Packages
    Hit http://archive.ubuntu.com trusty-updates/universe i386 Packages
    Hit http://archive.ubuntu.com trusty-updates/multiverse i386 Packages
    Hit http://archive.ubuntu.com trusty-updates/main Translation-en
    Hit http://archive.ubuntu.com trusty-updates/multiverse Translation-en
    Ign http://ppa.launchpad.net saucy/main Translation-en_US
    Ign http://ppa.launchpad.net saucy/main Translation-en
    Hit http://archive.ubuntu.com trusty-updates/restricted Translation-en
    Hit http://archive.ubuntu.com trusty-updates/universe Translation-en
    Hit http://archive.ubuntu.com trusty-backports/main Sources
    Hit http://archive.ubuntu.com trusty-backports/restricted Sources
    Hit http://archive.ubuntu.com trusty-backports/universe Sources
    Hit http://archive.ubuntu.com trusty-backports/multiverse Sources
    Hit http://archive.ubuntu.com trusty-backports/main amd64 Packages
    Hit http://archive.ubuntu.com trusty-backports/restricted amd64 Packages
    Hit http://archive.ubuntu.com trusty-backports/universe amd64 Packages
    Hit http://archive.ubuntu.com trusty-backports/multiverse amd64 Packages
    Hit http://archive.ubuntu.com trusty-backports/main i386 Packages
    Hit http://archive.ubuntu.com trusty-backports/restricted i386 Packages
    Hit http://archive.ubuntu.com trusty-backports/universe i386 Packages
    Hit http://archive.ubuntu.com trusty-backports/multiverse i386 Packages
    Hit http://archive.ubuntu.com trusty-backports/main Translation-en
    Hit http://archive.ubuntu.com trusty-backports/multiverse Translation-en
    Hit http://archive.ubuntu.com trusty-backports/restricted Translation-en
    Hit http://archive.ubuntu.com trusty-backports/universe Translation-en
    Hit http://archive.ubuntu.com trusty-security/main Sources
    Hit http://archive.ubuntu.com trusty-security/restricted Sources
    Hit http://archive.ubuntu.com trusty-security/universe Sources
    Hit http://archive.ubuntu.com trusty-security/multiverse Sources
    Hit http://archive.ubuntu.com trusty-security/main amd64 Packages
    Hit http://archive.ubuntu.com trusty-security/restricted amd64 Packages
    Hit http://archive.ubuntu.com trusty-security/universe amd64 Packages
    Hit http://archive.ubuntu.com trusty-security/multiverse amd64 Packages
    Hit http://archive.ubuntu.com trusty-security/main i386 Packages
    Hit http://archive.ubuntu.com trusty-security/restricted i386 Packages
    Hit http://archive.ubuntu.com trusty-security/universe i386 Packages
    Hit http://archive.ubuntu.com trusty-security/multiverse i386 Packages
    Hit http://archive.ubuntu.com trusty-security/main Translation-en
    Hit http://archive.ubuntu.com trusty-security/multiverse Translation-en
    Hit http://archive.ubuntu.com trusty-security/restricted Translation-en
    Hit http://archive.ubuntu.com trusty-security/universe Translation-en
    Get:4 http://archive.ubuntu.com trusty-proposed/restricted amd64 Packages [14 B]
    Get:5 http://archive.ubuntu.com trusty-proposed/multiverse amd64 Packages [14 B]
    Get:6 http://archive.ubuntu.com trusty-proposed/universe amd64 Packages [34.9 kB]
    Get:7 http://archive.ubuntu.com trusty-proposed/main amd64 Packages [63.9 kB]
    Get:8 http://archive.ubuntu.com trusty-proposed/restricted i386 Packages [14 B]
    Get:9 http://archive.ubuntu.com trusty-proposed/multiverse i386 Packages [14 B]
    Get:10 http://archive.ubuntu.com trusty-proposed/universe i386 Packages [35.2 kB]
    Get:11 http://archive.ubuntu.com trusty-proposed/main i386 Packages [60.8 kB]
    Hit http://archive.ubuntu.com trusty-proposed/main Translation-en
    Hit http://archive.ubuntu.com trusty-proposed/multiverse Translation-en
    Hit http://archive.ubuntu.com trusty-proposed/restricted Translation-en
    Hit http://archive.ubuntu.com trusty-proposed/universe Translation-en
    Ign http://archive.ubuntu.com trusty/main Translation-en_US                    
    Ign http://archive.ubuntu.com trusty/multiverse Translation-en_US
    Ign http://archive.ubuntu.com trusty/restricted Translation-en_US
    Ign http://archive.ubuntu.com trusty/universe Translation-en_US
    Ign http://archive.ubuntu.com trusty-updates/main Translation-en_US
    Ign http://archive.ubuntu.com trusty-updates/multiverse Translation-en_US
    Ign http://archive.ubuntu.com trusty-updates/restricted Translation-en_US
    Ign http://archive.ubuntu.com trusty-updates/universe Translation-en_US
    Ign http://archive.ubuntu.com trusty-backports/main Translation-en_US
    Ign http://archive.ubuntu.com trusty-backports/multiverse Translation-en_US
    Ign http://archive.ubuntu.com trusty-backports/restricted Translation-en_US
    Ign http://archive.ubuntu.com trusty-backports/universe Translation-en_US
    Ign http://archive.ubuntu.com trusty-security/main Translation-en_US
    Ign http://archive.ubuntu.com trusty-security/multiverse Translation-en_US
    Ign http://archive.ubuntu.com trusty-security/restricted Translation-en_US
    Ign http://archive.ubuntu.com trusty-security/universe Translation-en_US
    Ign http://archive.ubuntu.com trusty-proposed/main Translation-en_US
    Ign http://archive.ubuntu.com trusty-proposed/multiverse Translation-en_US
    Ign http://archive.ubuntu.com trusty-proposed/restricted Translation-en_US
    Ign http://archive.ubuntu.com trusty-proposed/universe Translation-en_US
    Fetched 198 kB in 49s (3,992 B/s)
    W: GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366
    W: Failed to fetch cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326)/dists/trusty/main/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

    W: Failed to fetch cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326)/dists/trusty/restricted/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

    W: Failed to fetch cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326)/dists/trusty/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

    W: Failed to fetch cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Beta amd64 (20140326)/dists/trusty/restricted/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

    E: Some index files failed to download. They have been ignored, or old ones used instead.

Any idea how to solve this?

  • W: Failed to fetch cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ this error will still appears if you failed to comment out the corresponding CDROM line in /etc/apt/sources.list file. – Avinash Raj May 17 '14 at 2:46
2

Run this command line in Terminal:

sudo echo "deb http://archive.ubuntu.com/ubuntu/ trusty main universe restricted multiverse" > /etc/apt/sources.list; sudo apt-get update
  • I don't know how about adding the universe,restricted,multiverse repositories will solves his problem. – Avinash Raj May 17 '14 at 2:44
  • well I don't know how this solved it but atleast now I am not getting the cd-rom error, Now I am getting something about a public key authentication "NO_PUBKEY A902DDA375E52366" – nabeel May 17 '14 at 2:49
  • @nabeel: It's a different problem. Run this command to fix the key problem: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366 In future, please use y-ppa-manager from Ubuntu Software Center when you want to add PPAs to Ubuntu. – Naveen May 17 '14 at 3:28
  • @AvinashRaj: His sources.list is wrecked. So resetting it to default fixes the problem. – Naveen May 17 '14 at 3:31
3

Just comment-out the line which consists of cdrom: in /etc/apt/sources.list file,

sudo sed -ri '/cdrom\:/ s/^(.*)$/#\1/g' /etc/apt/sources.list

Then update all the repositories,

sudo apt-get update
1

Just had a similar problem with me accidentally deleting old ppa's. I issued the following command and it restored my ppa's and allowed me to update using sudo apt-get update. The following command is:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366

Once that was done i was able to sudo apt-get update once again. Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.