0

I have an Asus G53JW and I can't manage to change the brightness anyhow (fn hotkeys are not working). I used Debian for 6 months and had the same issue and never found I way around this.

I did search a lot before posting and the best I could get was this (by @raaz), but it is a workaround and only change the gamma, not the actual brightness (this type of solution killed my battery before).

There is this other question regarding the same computer, but with no proper answer and it was related to 12.10, not 14.04 (my current version).

And I also tried xbacklight and brightness-controller without success.

Any idea? Thank you!

EDIT

It is really hard to find a solution: here is the proof. I've been search that long as well.

2

Copy-Paste from here this answer.

First

sudo sed 's/GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"/GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="/' -i /etc/default/grub

Second

sudo update-grub

Reboot your system and see if Fn (for brightness) works.

By NikTh

0

I really can't believe I found a solution for this after such a long time trying (way before I posted here...)

First, go to Settings > Software and Updates > Additional Drivers (this last one is a tab). Choose the official Nvidia driver (the latest and tested one).

Second, go to your terminal window and run sudo nvidia-xconfig. It will generate a xorg.conf file for you.

Third, go to that file and do as mentioned here (quote below)

This will open your X server configuration (after prompting for your password). You should see a section titled "Device" that looks as follows:

Section "Device"
      Identifier      "Default Device"
      Driver  "nvidia"
      Option  "NoLogo"        "True" 
EndSection 

Append a line so it appears like this:

Section "Device"
      Identifier      "Default Device"
      Driver  "nvidia"
      Option  "NoLogo"        "True"
      Option "RegistryDwords" "EnableBrightnessControl=1" 
EndSection

Lastly, restart you x server as mentioned here (quote below for lightdm. For the others is similar).

sudo restart lightdm

EDIT:

I just reused this method, and it worked again. For documentation purposes, my xorg.conf generated by sudo nvidia-xconfig was like this before including the "RegistryDwords" line:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

UPDATE:

For those of you having brightness problems in Debian (I tested for Debian 8), the solution provided above also works, but first instead of going to the Settings > Software and Updates > Additional Drivers you need to follow the 4 steps mentioned here.


EDIT Mar 31 2016:

For Ubuntu 14.04.4, it is also necessary to do what Crowell says in his answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.