0

I'm trying to install the php5-curl package, but I'm getting the dependency error:

The following packages have unmet dependencies:
 php5-curl : Depends: phpapi-20090626
             Depends: php5-common (= 5.3.10-1ubuntu3.11) but 5.5.5+dfsg-1+debphp.org~precise+2 is to be installed
E: Unable to correct problems, you have held broken packages.

I have found this guide here on Askubuntu, but I'm afraid that will downgrade my php installation to an older version, which I don't want.

This is the PHP version I have installed:

tomica@as5830tg-elementary:~/Documents/apktool$ php --version
PHP 5.5.5-1+debphp.org~precise+2 (cli) (built: Oct 28 2013 12:57:03) 
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
    with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies

Is there any way for me to keep the PHP 5.5.5-1 and still install php-curl?

  • File a bug report against php-curl and have the dependencies resolved by the package maintainer. – Panther May 16 '14 at 21:47
  • @bodhi.zazen that's a good idea. Do you have any advice how I should file a bug report for php-curl? – Томица Кораћ May 16 '14 at 21:48
  • You file a bug report on launchpad - bugs.launchpad.net – Panther May 16 '14 at 21:51
  • 1
    I have been using ppa:ondrej/php5 for PHP. This PPA includes php5-curl: php --version output: PHP 5.5.12-2+deb.sury.org~precise+1 (cli). In case you aren't aware, adding the PPA will update all PHP packages installed on your system to the latest in the PPA, assuming the PPA has a more recent version. Best performed on a test machine. – Paul May 16 '14 at 21:57
  • @Paul your advice worked for me. Thanks a lot. Would you please post it as an answer so that I can accept it? – Томица Кораћ May 16 '14 at 22:13
3

I have been using ppa:ondrej/php5 for PHP. This PPA includes php5-curl and FYI:

$ php --version

PHP 5.5.12-2+deb.sury.org~precise+1 (cli)

In case you aren't aware, adding the PPA will update all PHP packages installed on your system to the latest in the PPA, assuming the PPA has a more recent version. Best performed on a test machine.

If you are like me, you research who the owners and contributors of PPAs are. The owner and, so far, sole contributor to this PPA has a very high karma on Launchpad, regularly updates the PPAs he manages, and googling his email address reveals he is very active on a number of FOSS projects. As of the time of this answer, I consider the PPA reliable.

  • Thanks again @Paul. I know of that repository, I've been using it before. But apparently for some reason I forgot to add it since my last OS installation. Added, updated, upgraded, installed php5-curl with no problem. – Томица Кораћ May 16 '14 at 22:22
  • @ТомицаКораћ Awesome! I just added his Postfix repository to my test server. I can't report yet that it's great for that (though I suspect it is), but that's really due to the fact that I'm completely re-configuring my mail server. – Paul May 16 '14 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.