1

Today I've installed conky and gcalcli to create a background which shows my gmail agenda, but when I try to start conky I get the following error:

Conky: desktop window (2e0000a) is subwindow of root window (bf)
Conky: window type - override
Conky: drawing to created window (0x6000001)
Conky: drawing to double buffer
Traceback (most recent call last):
File "/usr/bin/gcalcli", line 392, in <module>
    class gcalcli:
File "/usr/bin/gcalcli", line 410, in gcalcli
    dateParser    = DateTimeParser()
File "/usr/bin/gcalcli", line 335, in __init__
    self.pdtCalendar = parsedatetime.Calendar();
File "/usr/lib/python2.7/dist-packages/parsedatetime/__init__.py", line 216, in __init__
    self.ptc = Constants()
File "/usr/lib/python2.7/dist-packages/parsedatetime/__init__.py", line 1733, in __init__
    self.locale = pdtLocales['icu'](self.localeID)
File "/usr/lib/python2.7/dist-packages/parsedatetime/pdt_locales.py", line 151, in __init__
    self.icu = pyicu.Locale(localeID)
icu.InvalidArgsError: (<type 'icu.Locale'>, '__init__', (None,))

I was unable to find a solution to the problem on the internet so I hope that you guys can help me?

The site which I have used for creating this is http://www.webupd8.org/2010/08/display-google-calendar-on-your-desktop.html

my rc file is:

alignment top_right
background no
border_width 0
cpu_avg_samples 2
default_color white
default_outline_color white
default_shade_color white
draw_borders no
draw_graph_borders yes
draw_outline no
draw_shades no
use_xft yes
xftfont DejaVu Sans Mono:size=12
gap_x 5
gap_y 60
minimum_size 5 5
net_avg_samples 2
double_buffer yes
out_to_console no
out_to_stderr no
extra_newline no
own_window yes
own_window_class Conky
own_window_type override
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
stippled_borders 0
update_interval 1.0
uppercase no
use_spacer none
show_graph_scale no
show_graph_range no
text_buffer_size 8096

TEXT
${execi 300 gcalcli --nc --cals=owner calw 4}
  • Pastebin your configuration files. – Panther May 16 '14 at 17:01
  • Try setting "own_window_type" to 'panel' – Itai Oct 30 '17 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.