7

I have a problem with my Ubuntu, running 14.04 LTS.

The problem is that I'm trying to user Alt+F4 and Alt+Tab and it doesn't work, it only works with the Right Alt.

I also tried to set a new keyboard short-cut for Alt+F4 and Alt+Tab but as soon as I press Alt the short-cut is set.

The thing I noticed once I set the shortcut is that the key didn't correspond with Alt, it was a Level3 Shift.

I search all over the internet of a method to change that Level3 Shift to the normal Alt but only found solution to do the opposite.

Any suggestions?

9
+50

Try xev and xmodmap:

  1. Run the command xev then hover your mouse over the black square.
  2. Press the Alt key, and make a note of the following: My output was this (shortened): KeyPress event... keycode 64 (keysym 0xffe9, Alt_L), ... XFilterEvent returns: False

  3. The important part is the keycode: Mine was 64, but yours is probably different.

  4. Run the command xmodmap -e "keycode 64 = Alt_L" substituting 64 for whatever output you get (possibly 135 on your keyboard)

  5. This should have changed it. If it has, you then need to run the following command: xmodmap -pke >~/.Xmodmap

  6. Create a file called .xinitrc in your home folder (/home/username)

  7. In that file paste the line xmodmap .Xmodmap. This should save it forever.

See this answer for details about remapping.

My pronouns are He / Him

5

Both of these solutions were a bit too hacky for my taste, so I dug a little deeper. The solution I found only uses dconf-editor.

Just open dconf-editor and search (ctrl+F) for xkb-options and update the value. In my case, the value associated with the xkb-options key was

['terminate:ctrl_alt_bksp','lv3:alt_switch']

The option 'lv3:alt_switch' was the one that was causing my headache. I simply changed the value to:

['terminate:ctrl_alt_bksp']

That's it!

2

Check current layout defaults

  1. Check used layout/variant names, example my case:

    $ setxkbmap -query
    
    rules:      evdev
    model:      pc105
    layout:     us,us
    variant:    altgr-intl
    
  2. Open the file in /usr/share/X11/xkb/symbols/ with same name of layout.

    sudo nano /usr/share/X11/xkb/symbols/us
    
  3. Scroll down to the exact variant

    xkb_symbols "altgr-intl" {
    
     name[Group1]= "English (international AltGr dead keys)";
    
    ...
    
    include "level3(ralt_switch)"
    };
    
  4. See if you have include "level3(ralt_switch)" (or maybe include "level3(lalt_switch)", not sure if that's possible), if so remove its line.

  5. Run to update layout

    sudo dpkg-reconfigure xkb-data
    
  • I have eek@Eek-PC:~$ setxkbmap -query rules: evdev model: pc105 layout: us options: lv3:lalt_switch and when i modified altgr-intl and removed the include line didn't changed, also, I didn't had any xkb_symbols lv3:lalt_switch. But the other answer helped. Thanks! – Eek May 26 '14 at 12:33
  • @Eek, Never mind, Your current layout is us basic not altgr-intl. However, You have options: lv3:lalt_switch, I don't known any thing may come up with this as default, Did you made any customized settings? – user.dz May 26 '14 at 14:03
  • Nope. Default Ubuntu install :-s I have an Asus G74SX maybe from that's where the problem comes :-s – Eek May 27 '14 at 6:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.