I did a fresh install of trusty 14.04, but a lot of icons are missing. I installed from DVD which was painfully slow and I hope to avoid repeating the process, especially since I started customizing stuff.

Here's my settings window:

System Settings

I've tried:

sudo apt-get install --reinstall gnome-control-center
sudo apt-get install --reinstall gnome-settings-daemon-schemas

None of which changed anything.

Any idea? I wanna edit preferences and none of them are in System Settings, neither in Unity Dash.


4 Answers 4


I had exactly the same problem - same icons missing as well. I had stupidly uninstalled gnome-bluetooth, and nothing was fixing it. So I did what user282306 (r00t) suggested -

sudo apt-get install ubuntu-desktop

And I've got them all back again.

Kudos @user282306 (previously r00t) for the suggestion.

  • I don't understand why in the hell there are not this settings apps by default...
    – logoff
    Apr 17, 2015 at 10:24
  • @logoff there are. This would happen after a bad install or removing a package that you shouldn't - basically anything that starts with gnome-, for example gnome-bluetooth.
    – Tim
    Apr 17, 2015 at 10:27
  • @Tim so strange, I did a fresh install on a VM adding a few new packages, not removing.
    – logoff
    Apr 17, 2015 at 11:06
  • Was one of those gdm or part of a GNOME shell?
    – Tim
    Apr 17, 2015 at 11:14
  • 1
    That's overkill for what is needed. unity-control-center is all that is needed.
    – Ken Sharp
    Feb 9, 2016 at 9:43

This issue was resolved for me by (re-)installing unity-control-center

apt-get install unity-control-center.

I didn't want to re-install the whole ubuntu-desktop because it was going to install a bunch of packages I didn't want/need and use another 100MB of space.

Compared to just 4MB with unity-control-center

  • Very effective solution. Had the same problem and the above solved it for me. Thanks
    – darbehdar
    Feb 11, 2016 at 10:41

Most likely (probably due to some dependency issue) below packages were removed:

  • unity-control-center-signon
  • gnome-control-center-unity

This command should resolve this issue:

sudo apt-get install unity-control-center-signon gnome-control-center-unity
  • This has to be the most annoying problem out there. Thanks. This fixed it for me.
    – Sonny
    Nov 23, 2014 at 1:17

If you use Awesome WM, to start the settings panel, use either of:

  • (17.04+)

    XDG_CURRENT_DESKTOP=Unity7 unity-control-center
  • (16.10-)

    XDG_CURRENT_DESKTOP=Unity unity-control-center

See unity-control-center icons missing when using xsession desktop with awesome window manager


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .