In , how can I switch between users on the console without entering a ? This has been asked by others many times over the years (such as here), and it seems it always gets redirected to something else that's close but not the same. So, I'll try to be exact in the use case below, to avoid any misunderstandings of the goal. Sorry for the length.

  • The sole reason for switching between users is so family members at our home can have their own browser favorites/history, their own unity session prefs (I use dvorak and swap esc/capslck), etc. We use a BIOS password to prevent routine machine access; amongst ourselves is not a concern. We don't use any drive or mount point encryption, so I've no illusions of protection after physical theft.

  • I do want a password on my account, so I can authenticate for system updates, authenticate with sudo for various activities, scp between various machines, etc.

  • I would prefer to be prompted for a password if I'm not already logged into the console, but not again when just switching from other users. If I'd ever feel the need for a session lock, I could live with just logging out instead, though it's not preferable.

  • An ubuntuforums hack for 12.04 of uninstalling gnome-screensaver worked well for that old release, but doesn't work under 14.04.

  • Setting disable-lock-screen (per a couple ways here) also doesn't work.

  • Settings|Brightness|Lock=OFF doesn't help

  • Because this is important for us, I'm willing to try other flavors (lubuntu, xubuntu) or even other distros to get this functionality, but prefer from the main ubuntu distro.

Following the idea here, I'm currently test driving password-less standard accounts, and using password-protected administrator account (not root) for software updates, scp commands, etc. This mostly accomplishes the goal, and (since I'm old-school) it feels right to use a dedicated admin acct for admin-ish things, but I'd still like the option to lock my session.

(If this is a missing feature, I'm thinking launchpad is the best avenue for submitting a feature request; correct me if I'm wrong.)

  • If you want to disable the graphical login screen edit /etc/default/grub – Banned_User May 16 '14 at 5:01

add user

sudo adduser -m -s /bin/bash 

-m means add home directory, -s means the following is their login shell

remove user password

sudo passwd -d USERNAME

now to allow passwordless logins you need to edit a text file

pico /etc/pam.d/common-auth 


gedit /etc/pam.d/common-auth 


auth [success=1 default=ignore] pam_unix.so nullok_secure


auth [success=1 default=ignore] pam_unix.so nullok




To revert your change simply re-add "_secure" at the end. Or just make a backup of the original file

cp /etc/pam.d/common-auth /etc/pam.d/common-auth.BACKUP

I believe the main reason *nixers are so obnoxious about passwords is actually to protect network data moreso than physical drive data. That said there is a time and place for EVERYTHING. imo. I run apache/ircd/smtp as root because its on my old android on a sandboxed network.

|improve this answer|||||

This works in 14.04 - http://ubuntuhandbook.org/index.php/2013/07/login-without-a-password-on-ubuntu/

With gnome-system-tools & their "Users and Groups"

|improve this answer|||||
  • 1
    Links as an answer are not good for future references (that site might move or get deleted making it go to an error 404 page). It is preffered to create answers. – Rinzwind Jun 13 '14 at 10:29
  • On my system (debian jessie) the option “Don’t ask for password on login” was grayed out. Upon reading this bug report and the associated patch, I added “auth sufficient pam_succeed_if.so user ingroup nopasswdlogin” to /etc/pam.d/gdm-password, created the nopasswdlogin group and rebooted. Now the option is not grayed out any more and works. Note that I don’t know how secure this modification is as I don’t know how PAM works. – Olivier Cailloux Sep 20 '15 at 9:33

Try this answer from an earlier release.


gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'

Do for each user who doesn't want to be bugged with login when switching.

Works for 12.04, but don't know about 14.04 (my 14.04 system is single-user).

This really isn't a duplicate of that earlier question since a lot changed when Canonical went their own way.

|improve this answer|||||

We faced a very similar problem here. We tried very similar workarounds on 12.04 until we had something that worked well. But it did not work in subsequent releases.

So I opened Switching between two opened X sessions without reauthenticating and posted a solution there.

Current solution is a proof-of-concept but I'm sure it can be improved.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.