I just installed ubuntu on my laptop, everything works fine, but I'd like to use chrome instead of firefox. I downloaded the .deb file from the chrome website, and when I open it, the install buton inside the software center is inactive (I can't click it) and it's telling me dependency is not satisfiable: libcurl3

I did a search for libcurl3 in the Software Center, the three results I'm getting are already installed. Any ideas how to fix this?

I also tried installing chromium-browser, but that's not working out neither. I'm getting Package dependencies not resolved and this details block:

The following packages have unmet dependencies:

chromium-browser: Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
                  Depends: libxdamage1 (>= 1:1.1) but 1:1.1.3-1ubuntu1 is to be installed
                  Depends: zlib1g (>= 1: but 1: is to be installed
                  Depends: libnss3-1d (>= 3.12.3) but it is not going to be installed
  • I am getting this kind of Error while installing chrome in ubuntu system. Error: Dependency is not satisfiable: gconf-service – user257002 Mar 11 '14 at 6:44
  • possible duplicate of How do I resolve unmet dependencies? – Eliah Kagan Sep 13 '14 at 3:37

Here's how to fix it.

Close Ubuntu Software Center (important if it's open!).

Run the following command in a terminal (To open a terminal, hit Alt-F2 and type in gnome-terminal)

sudo apt-get update && sudo apt-get install -f

Once that's done, Google Chrome should be finished installing.

As per a comment asking for more info, here's what that command does.

The -f switch in apt-get auto-corrects broken dependencies. The issue you had was a broken dependencies (so Google Chrome needed a package it didn't have).

  • 3
    Worked for me, but I had to close Ubuntu Software Center first. – Seth May 12 '15 at 15:48
  • Not that I have a problem but can I ask your opinion about something? I don't think the problem originated from the fact that there was a broken dependency but did from the fact that repos were not updated alone. sudo apt-get update alone solved that. Do you think that it can be the case? – SarpSTA Aug 28 '16 at 19:58

One of the comments above has already mentioned this, but I would put this as the answer for your question.

All you need to do to install Chromium (read Chrome) in Ubuntu:

sudo apt-get install chromium-browser

(it's in the universe repository)

Consider installing Chromium instead. This is what is maintained by the community. Among their differences is it lacks Google branding, it doesn't have a built-in Flash Player and doesn't have a built-in PDF viewer. You still use the same plugins (even from the same Google webpage), themes etc. Using Chromium you will be sure to receive all the security and other updates, etc. If you still want the Chrome instead, just add their PPA.

P.S. Here are some useful commands to check your packages when something like that you experienced happens:

sudo apt-get update     # updates lists of packages (for example, you run this when you add new repositories or PPA's)
sudo apt-get check      # verifies that there are no broken dependencies
sudo apt-get -f install # -f auto-corrects broken dependencies
  • It doesn't have a built-in flash player - other than that, there is no difference. – jrg Jun 17 '11 at 21:59

protected by Community Nov 14 '14 at 9:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.