54

I noticed that my Ubuntu is lagging EXTREMELY badly but only the first time I do things after what I did gets loaded into RAM the lag stops totally. I ran some tests and I guess one of my laptop hard drives is borked.

Im assuming that I have to replace the drive, is there some command I can issue to see the exact specs on the drive so I can then buy it online?

I don't want to have to open up the laptop, find the specs. Then open it again when the new drive arrives.

3
  • Or is there another cool hacky command or way to partition my drive to avoid using the bad spots? A while ago when my drive failed I mounted it useing an alternative superblock and this worked and still does i guess.. May 15 '14 at 13:42
  • 3
    I found the hacky solution I wanted. I ran the command "badblocks /dev/sda1" and then noticed they were all near the front of the drive. So I created an unallocated partition at the front of the drive consisting of 50% of the total size. I then tested the second half of the drive! AND WALAAAAAAAA!!!!!! IT WORKED!!!!! Im going to buy a new drive anyway but this process taught me alot :) May 15 '14 at 17:01
  • I'm happy for you.
    – avia
    May 15 at 22:02
52

smartctl command from smartmontools package is what you want for that

% sudo smartctl -i /dev/sda
smartctl 6.2 2013-07-26 r3841 [i686-linux-3.13.0-24-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family:     SAMSUNG SpinPoint M7
Device Model:     SAMSUNG HM250HI
Serial Number:    <snip>
LU WWN Device Id: 5 0024e9 203520f1d
Firmware Version: 2AC101C4
User Capacity:    250,059,350,016 bytes [250 GB]
Sector Size:      512 bytes logical/physical
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS T13/1699-D revision 6
SATA Version is:  SATA 2.6, 3.0 Gb/s
Local Time is:    Thu May 15 21:49:09 2014 MYT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
1
  • That's a great answer thank you.
    – avia
    May 15 at 22:02
25

You can use lshw tool :

Install :

sudo apt-get install lshw 

Command for H.D.D Specs:

lshw -class disk -class storage
8
  • 1
    Thanks I hope this helps someone but the first answer was PERFECT so im not even bothering with this, do you know if I can somehow use only part of my hard drive? The hole thing still works but super slow. I know nothing of hardware but maybe there is a way to say only use the good part of the hard drive? Maybe when hard drives go bad only certain portions go bad? May 15 '14 at 14:06
  • Try to test it for bad boot sectors and repair them .
    – nux
    May 15 '14 at 14:41
  • ok i will try to help you mate .
    – nux
    May 15 '14 at 14:47
  • 2
    you are welcome my friend :) happy to hear that
    – nux
    May 15 '14 at 17:34
  • 1
    On my system this only shows the controllers and not the attached SSD. May 17 '19 at 20:49
21
% sudo hdparm -I /dev/sda                                                                      ~

/dev/sda:

ATA device, with non-removable media
        Model Number:       WDC WD10JPCX-24UE4T0                    
        Serial Number:      WD-WXR1E24A7U0E
        Firmware Revision:  01.01A01
        Transport:          Serial, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0
Standards:
        Supported: 9 8 7 6 5 
        Likely used: 9
Configuration:
        Logical         max     current
        cylinders       16383   16383
        heads           16      16
        sectors/track   63      63
        --
        CHS current addressable sectors:   16514064
        LBA    user addressable sectors:  268435455
        LBA48  user addressable sectors: 1953525168
        Logical  Sector size:                   512 bytes
        Physical Sector size:                  4096 bytes
        Logical Sector-0 offset:                  0 bytes
        device size with M = 1024*1024:      953869 MBytes
        device size with M = 1000*1000:     1000204 MBytes (1000 GB)
        cache/buffer size  = 16384 KBytes
        Nominal Media Rotation Rate: 5400
1
  • 2
    A simple command that's installed by default with all the info I was looking for. Have an upvote!
    – mkasberg
    Feb 13 '19 at 5:08
15

You can use lsblk, it has a ton of options that you can use e.g.:

lsblk -o MODEL,SIZE,NAME -d

which gives this result in my case

MODEL              SIZE NAME
Samsung SSD 850  232.9G sda
Samsung SSD 850  931.5G sdb
11

$ lsblk

The command lsblk by default will list all block devices in a tree-like format. Type lsblk --help to see more options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.