23

I'm running Ubuntu 14.04 LTS, and I have an HD 4600 integrated graphics chip.

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

Intel just released the new version of their Graphics driver for Ubuntu 14.04.
https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-1.0.5-linux

When I try to install it, I get stuck at:

Finished : E:GPG error: http://download.01.org trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)  [  ] ◦
main-window.c/on_transaction_finished: Package transaction finished with an error

And it prevents sudo apt-get update from completing. I get the same error as before.

I went to Software & Updates and under Other Software tab I removed the bad repository: http://download.01.org/gfx/ubuntu/14.04/main, and then I could update my repositories. But I cannot install the Intel Graphics Driver!

I hope I'm making sense. This is the first day this is available, so I'm counting on Intel to fix this soon, if not, I hope someone can help find a work around.

8

3 Answers 3

38

The installer contains the wrong repository url. To fix this you need:

  1. Start the installer and try to install, you got error, close installer.
  2. Open console and type:

    sudo -H gedit /etc/apt/sources.list.d/intellinuxgraphics.list
    
  3. Replace text with text below, don't close gedit just leave it:

    deb https://download.01.org/gfx/ubuntu/14.04/main/ trusty main #Intel Graphics drivers
    
  4. Start the installer again, press Begin button, press Install button and fast switch to gedit and hold CTRL+S.

    sudo apt-get update may yield:

    GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366
    

    Fix it with:

    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366
    
5
  • 2
    Had to try it a few times to get it to work, but it does indeed do the trick. Thank you very much! May 16, 2014 at 5:23
  • Also, something to add, "apt-get update" yielded: GPG error: download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366 So I fixed it with: sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366 May 16, 2014 at 5:34
  • 3
    Failed to fetch download.01.org/gfx/ubuntu/14.04/main/pool/main/i/… Size mismatch
    – akikara
    May 16, 2014 at 13:28
  • I think form mine I had to hit save right as it showed "Setting up Repositories" otherwise I think holding it down hit a repeat limit or something.
    – Mateo
    May 16, 2014 at 15:13
  • 1
    adding a key with apt-key adv is considered a security risk. ubuntuforums.org/showthread.php?t=2195579 see here debian.org/doc/manuals/securing-debian-howto/…
    – mchid
    Aug 9, 2014 at 23:10
2

Here's the easier solution for those with problems:

  1. Open Nautilus(file explorer), go to Edit -> Preferences -> Behavior, and make sure that under Executable text files, Ask each time is selected! (if not, select it)
  2. Close the window
  3. Open Nautilus (if not already open)
  4. Right click New document > Empty document
  5. Name it script.sh
  6. Open it and enter this:

    #! /bin/bash
    while [ 1 ]; do
        sudo sed --in-place 's/http:/https:/g' /etc/apt/sources.list.d/intellinuxgraphics.list
        sleep 1
    done
    
  7. Save it and close it

  8. Right click on script.sh and select Permissions
  9. Check Allow executing this file as program
  10. Close the window
  11. Double click it
  12. Select Run in terminal
  13. Enter password
  14. DO NOT close the terminal
  15. Begin installation, and everything should work

I also got Failed to fetch download.01.org/gfx/ubuntu/14.04/main/pool/main/i/… Size mismatch error and this fixed the problem. You can delete script file and close the terminal when the installation is finished.

Edit: There is simpler way:

  1. Enter this in terminal:

    #! /bin/bash
    while [ 1 ]; do
        sudo sed --in-place 's/http:/https:/g' /etc/apt/sources.list.d/intellinuxgraphics.list
        sleep 1
    done
    
  2. Enter password

  3. Run the installer
4
  • 2
    you can as well just paste that in shell :)
    – psukys
    May 16, 2014 at 19:20
  • Should it be "#!/bin/sh" instead of "#!/bin/bash"? I'm sure it will run either way, I'm just asking because I don't know the answer.
    – mchid
    Aug 10, 2014 at 20:29
  • To be honest, I don't know the difference too. Aug 10, 2014 at 22:23
  • Functionally, there is no difference between the two. Sep 28, 2014 at 2:56
0

Use gdebi to install the intel-linux-graphics-installer and you won't have the GPG problems. It should automatically install with the deb package. Use the following commands to do so:

sudo apt-get update && sudo apt-get install gdebi
cd && wget https://download.01.org/gfx/ubuntu/14.04/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb
sudo gdebi intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb
intel-linux-graphics-installer

Follow the instructions displayed in the GUI to update your system. Save any unsaved work and reboot for the changes to take effect.


Furthermore, using

sudo apt-key adv

Is considered a security risk and is not recommended as you are "undermining the whole security concept as this is not a secure way of recieving keys for various reasons (like: hkp is a plaintext protocol, short and even long keyids can be forged, …)". http://ubuntuforums.org/showthread.php?t=2195579

I believe the correct way is to first import the key

GET https://download.01.org/gfx/RPM-GPG-KEY-ilg | gpg --import

Check the fingerprint

gpg --check-sigs --fingerprint 75E52366

Get the key from the keyserver

gpg --keyserver pgpkeys.mit.edu --recv-key 7CB0FA13

Export the key to your keyring

gpg -a --export 75E52366 | sudo apt-key add -

Repeat for second key

GET https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 | gpg --import

gpg --check-sigs --fingerprint 2F4AAA66

gpg --keyserver pgpkeys.mit.edu --recv-key 144BD458

gpg -a --export 2F4AAA66 | sudo apt-key add -

more info http://www.debian.org/doc/manuals/securing-debian-howto/ch7.en.html#s-deb-pack-sign

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .