1

I use a High-DPI monitor on my Lenovo Yoga2 Laptop (like a retina display) so I have to change the overall font-scaling.

There are many ways to set the text-scale-factor, for example dconf-editor, I used unity-tweak-util, but in the end they seem to set the values in the global configuration:

$ gsettings list-recursively|grep text-scal

org.gnome.desktop.interface text-scaling-factor 2.0
com.canonical.Unity.Interface text-scale-factor 2.0

This solves it (for most programs) and everything is in a readeable size.

Now the Problem:

When I boot my PC this setting seems to take effect later than the desktop is booted, cause when I instantly open nautilus when the desktop is up, I still have it all in a tiny font. If I wait some 10 seconds more and start nautilus then, I have it scaled the right way.

I checked right after boot-time, I opened a console and watched the output of gsettings list-recursively|grep text-scal - the setting is already on 2.0, but everything is still tiny.

How can I achieve one of these solutions?

  1. change this behaviour and get the font scaled right from the start?
  2. make the desktop wait for the setting to be active?
  3. generate a warning that the scaling is not set yet?
-1

It is not a solution to 3. but a workaround, and faster than opening nautilus again and again:

I now open a console and look at its font-scaling. In the beginning it is still with a tiny font, I now wait until the console switches to the bigger scaled font.

In fact, I added the dropdown console tilda to my autostart programs so I automatically have a console at start and just wait some seconds until the font-size is loaded

| improve this answer | |
  • Why do it faster the process for tilda but not for nautilus? – Anwar Nov 5 '16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.