I have just installed VMWare 10 on my Dell PC, and installed Ubuntu 14.04. Now I am having trouble mount /cdrom. Here's what I have tried:

mkdir /mnt/cdrom
mount /dev/sr0 /mnt/cdrom
mount: no medium found on /dev/sr0

Actually, I do have a cd in the cdrom, and Window 8 was able to read document out of this CD. I need advice on how to resolve this error. I am a newbie here. thanks!

  • What's the output of ls /dev/sr*. Try to mount after reboot, without launching vmware.
    – totti
    Jul 27, 2014 at 10:00
  • @André Marinho why no response? See above comment.
    – totti
    Jul 30, 2014 at 5:59
  • The output is /dev/sr0 Aug 3, 2014 at 2:37
  • @AndréMarinho please see if this helps vmware.com/support/ws5/doc/ws_disk_add_cd_dvd.html
    – precise
    Aug 3, 2014 at 4:46
  • What trouble do you have? I just did your commands on LinuxMint 17 just fine. Notice, you need to run mkdir /mnt/cdrom as root, i.e., sudo mkdir /mnt/cdrom
    – user
    Oct 16, 2018 at 21:28

4 Answers 4


Install VMware tools using the open-vm-tools package.

apt-get install open-vm-tools

Any other driver install is legacy officially.

  • Ubuntu as Guest OS in VMWare on Windows 8 host.
  • Host has access to CDROM, but not guest OS.

    Check VMWare settings... there must be something either locking out - or not enabling - CDROM access for the guest OS.

From your description it sounds like your drive is not connected to the VM. To connect the drive the follow the steps below. go to vm settings configure how you the cd drive to be connected

If this is not what you're looking for, please add more details to your question.

  • I got this: devfsadm: command not found Aug 3, 2014 at 4:12
  • @AndréMarinho I really got confused in the first place, I now edited the answer. Aug 3, 2014 at 12:13
  • @RuslanGerasimov And in ubuntu server, how to mount it?!
    – Dr.jacky
    Sep 14, 2015 at 3:55

I had the same problem on a CentOS 5.11 VM. The VM had the CD-ROM enabled, and also enabled on boot yet I got the "no medium found" error. The fix was to disable the CD-ROM on the VM, click "OK", let the machine reconfigure, then re-enable the CD-ROM, click "OK" again, and let the machine reconfigure again.

I suspect that the OS had "ejected" the CD at some point and this IT Crowd style solution ("Turn it off and back on again") reset that state.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.