1

I am trying to switch to single user mode in 14.04. I tried

sudo telinit 1

but this never gives you a prompt.

I then tried editing the boot options from the grub menu when I reboot. I see a line that ends

ro quiet splash $vt_handoff

but if you add the word single in there you never get a prompt.

This problem appears to be reproducible by others.

How do you get into single user mode?

  • @user68186 The problem is that seems outdated now as the answer doesn't work in 14.04. – felix May 14 '14 at 19:29
  • Try changing virtual consoles, ctrl-alt-F2 for example. If that fails, please identify your graphics card. – Panther May 14 '14 at 19:49
  • @bodhi.zazen Do you mean change virtual console after doing "sudo telinit 1"? I am not ever sure ubuntu has runlevels does it? – felix May 14 '14 at 19:54
  • 1
    To a large extent, "runlevels" are depreciated with both upstart and systemd. Ubuntu is moving to systemd, see fedoraproject.org/wiki/Systemd "systemd has the concept of targets which is a more flexible replacement for runlevels in sysvinit." I respectfully suggest you at least take a look at systemd ;) – Panther May 14 '14 at 21:28
  • 1
    I do not use Ubuntu 14.04. If it is not working, you probably will need to file a bug report and use a live USB to make changes / repairs. What are you trying to do that you can not use sudo -i from a graphical desktop? – Panther May 15 '14 at 15:42

Browse other questions tagged or ask your own question.