3

I recored a movie by Samsung TV and It has a .TS format, and I can't play it. I tried VLC and Smplayer. None of them work.

In VLC I get this Error:

[0x7fbc40c018b8] ts demux error: libdvbpsi (misc PSI): Bad CRC_32 table 0x73 !!!
2
  • 1
    possible duplicate of ".ts " files not recognised
    – int_ua
    Commented May 14, 2014 at 19:11
  • Near duplicate because for Samsung it can at least partly be answered as we do have both, an alternative firmware as well as decryption tools. This may not be the case for other brands.
    – Takkat
    Commented May 14, 2014 at 19:29

3 Answers 3

6

There is no application for Ubuntu with a genuine support for Samsung PVR recordings.

PVR recordings from a Samsung TV are encrypted to meet DRM. In order to view them on a device other than the very TV on which they were recorded we would have to decrypt them first.

Doing so may be illegal depending on copyright laws in your country.

Some older Samsung TVs stored the encryption key together with the video files on an attached USB drive but this is not the case in newer series.

For these we need root access to the TV firmware in order to read the encryption key generated from the TV before we can decrypt our recordings. You will find some tools including tools for Linux/Ubuntu from the SamyGo modified firmware support forums.

You may be able to adapt them to your settings better than me because my TV is not supported without also replacing it's firmware (which I did not want to do). Not all series of Samsung TVs are supported however.

1
  • This question looks like a duplicate, but this answer is great. I think the questions should be merged to not lose it.
    – int_ua
    Commented May 14, 2014 at 19:13
0

Here is how you can decrypt the Samsung PVR files

http://www.ivonet.it/Linux/Samsung.LED.TV.PVR.Recording.As.MKV

It worked fine for me.

-1

Did you try to play them with Smplayer ?

Smplayer can play this type of videos but you cannot rewind or fast forward. You can only watch it. I run Linux Mint 17 and all multimedia files play normally except .ts files which play in Smplayer only. I have installed the following packages ubuntu-restricted-extras - Smplayer which are not installed by default in Linux Mint 17. I hope this can help. Edited from this point :) I do a work around to solve this issue I use WinFF app to convert the .ts file to any other file that play normally which in my case I prefer the following settings in winff

Convert to : ( I choose DVD ) Preset ( I select PAL DVD fast LQ)

Preset settings can change according to your needs of course :) Cheers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .