2

So after about an hour trying to find a solution for this problem, I've had no luck.

The issue:

Audio playback in Google Chrome is way too fast/high pitched/choppy.

Steps I've taken to try and fix this:

Website used for the test between Firefox/Chrome: Google Music (music.google.com)

Tested other browsers (Firefox). Audio was fine.

Went to chrome://plugins. Disabled the Adobe Flash plugins one by one to test. I have the following plugins installed:

enter image description here

and the flash plugins:

enter image description here

Neither of those worked. Additionally, disabled the VLC plugin to test. That did not work.

Uninstalled/reinstalled alsa and pulseaudio. That did not work.

Changed sample rate in pulseaudio to 48000. That did not work.

I'm really at a loss for what the issue is. Like I said, the audio in firefox is fine.

Any suggestions?

  • Try deleting the google-chrome folder in .config in your home folder and then relaunch Chrome. This way you're starting fresh. If the issue still persists you'll know it's not with your Chrome configuration. If it stops you'll know it was a configuration issue. Deleting a disabling features in a random attempt to isolate the issue could lead you to bigger issues so starting with the lowest common denominator is best. – C.Jacobs May 14 '14 at 14:45
  • I got the same problem here... Waiting for help. I tried what C.Jacobs proposed but that didn't work for me. – user305520 Jul 14 '14 at 19:52
4

Things to try:

  1. check flashplayer in chrome-plugins
  2. delete ~/.config/google-chrome
  3. reinstall alsa and pulseaudio

    sudo apt-get remove --purge alsa-base pulseaudio indicator-sound
    sudo apt-get install alsa-base pulseaudio indicator-sound
    sudo alsa force-reload 
    
  4. kill pulseaudio (worked for me!)

    killall pulseaudio; rm -r ~/.config/pulse/* ; rm -r ~/.pulse*
    
  • 2
    None of these things helped Chrome play audio (and I can't say I'm surprised; my audio works fine in general and Chrome is the only application with a problem). – Pointy Sep 25 '14 at 16:49
  • 4th solution worked for me. Thanks! – jessenorton Apr 12 '15 at 19:52
2

sudo apt-get remove --purge alsa-base pulseaudio indicator-sound

sudo apt-get install alsa-base pulseaudio indicator-sound

sudo alsa force-reload

The above worked for me. I tried everything: reinstall, remove ~/.config/google-chrome, html5 audio, etc...

  • This worked for me, but the last command didn't pulled through. – Miguelgondu Jun 14 '16 at 4:28
0

To fix this issue, you could install Pepper Flash Player, a safer and more stable version of Flash Player from Google. An Adobe Flash Player Pepper installer is available in Ubuntu 14.04 repositories. This installer downloads Google Chrome, extracts Pepper Flash Player and sets it up for Chromium usage.

sudo apt-get install pepperflashplugin-nonfree
sudo update-pepperflashplugin-nonfree --install
0

To me the problem occurs when I change the audio to HDMI after plug the cable and do not return to the notebook's sound card before removing the cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.