5

pavilion dv6 It worked previously but I uninstalled the fglrx and tried to reinstall it. I tried installing it via additional drivers as well as the Ubuntu AMD Catalyst install tool as well as downloading it from the AMD homepage and building a deb as well as just running the script.

I searched the web for a solution for 3 hours now.

lspci | grep VGA & sudo lshw -C video
[1] 4686
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] (rev ff)


*-display               
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:53 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:6000(size=64)
[1]+  Done                    lspci | grep --color=auto VGA

help is much appreciated

  • can you elaborate on how to run "amdcccle" to select both cards? Where is this executable located? Is it a GUI or a commandline tool? – Philipp May 28 '14 at 1:44
3

I followed the exact steps mentioned in this blog post: Install AMD hybrid (dual graphics) in Ubuntu and it worked for me just fine:

Open the terminal and run the following command:

sudo apt-get install fglrx fglrx-core fglrx-amdcccle fglrx-dev fglrx-pxpress

Now you should run the following command:

sudo amdconfig –initial –adapter=all

...but this will give you an error: no supported adapters detected.

Don’t worry and reboot the system, and you will be introduced with a black screen, but there is no need to panic.

Now press the keyboard combination Ctrl+Alt+F1 and then you will get a text-only console which shows you a login prompt. Login using your user name and password and then retype the command:

sudo amdconfig –initial –adapter=all

If you’re lucky enough, the command will get executed successfully. Reboot and you will be able to use your computer.

To make sure that the AMD graphics card is the one in use run:

sudo apt-get install mesa-utils
glxheads  

It should print: GL_VENDOR: ATI Technologies Inc.

  • Rebooting didn't help. It still finds no supported adapters. – Cerin Jan 3 '15 at 4:56
  • When rebooting did you find a black screen or you logged in normally. if you logged in normally try glxheads to find out if it's installed correctly. In newer versions simply installing the packages work without amdconfig. – fady mohamed osman Jan 3 '15 at 13:04
  • 1
    Turned out, I had to uninstall the fglrx package, with is the crappy proprietary ATI driver that drops support for all cards older than a couple of years, but still disables the built-in open source driver that works perfectly. – Cerin Jan 6 '15 at 14:48
  • 1
    Running amdconfig from the text-only console after rebooting worked for me (Dell M2800 with FirePro graphics). Thanks! – Matthew Read Jun 12 '15 at 22:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.