The Problem

The issue I am facing is that I get the following error on boot, after I select Ubuntu in GRUB:

Error: File "/vmlinuz-3.13.0-24-generic.efi.signed" not found.  
unaligned pointer 0xd0a26c68
Aborted. Press any key to exit.

Error: File "/vmlinuz-3.13.0-24-generic.efi.signed" not found.

I already posted a question regarding this issue here, but as a lot of things changed, I set up this question.

My Setup

I had some different troubles to play around if during installation, as I have a setup with a fully encrypted root. Plus, there were issues with the UEFI and GPT, especially to get everything work with Windows. As the install was a long time ago, I don't remember any details.

On my Ubuntu harddrive, I have three main partitions:

  • /dev/sda1: fat32, boot flag.
    This should be the EFI partition (/boot/efi, isn't it?)
  • /dev/sda2: ext2
    Should be /boot
  • /dev/sda3: crypt-luks
    The encrypted container, contains root and swap


In a live system I started from a USB, I found the following issues:

Error in nautilus

Clicking on the mounted boot-Partition (/dev/sda2) in nautilus gives the following error:

Sorry, could not display all the contents of “boot”: Error when getting information for file '/media/ujosh/root/boot/System.map-3.11.0-17-generic': Input/output error

Sorry, could not display all the contents of “boot”: Error when getting information for file '/media/ujosh/root/boot/System.map-3.11.0-17-generic': Input/output error

Error updating initramfs

Nevertheless, I could mount all three partitions and bring them together via mount --bind in the right constellation so I could chroot into my system. There, I ran

apt-get update
apt-get dist-upgrade

Everything worked as expected until

update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
cat: /proc/cmdline: No such file or directory

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.13.0-24-generic with 1.
dpkg: error processing package initramfs-tools (--configure):
subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

boot-repair doesn't help

I as well ran boot-repair on the setup, which eventually triggered the same errors while updating the initramfs as above.

Running file system checks

By the help of @zoid, I used the following tests on my /boot-partition:enter code here

sudo fsck.ext2 -p -f -C0 /dev/sda2
/dev/sda2: Inode 29 has illegal block(s).  

    (i.e., without -a or -p options)

sudo fsck.ext2 -f -C0 /dev/sda2

results pasted here

sudo smartctl -H /dev/sda 
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.13.0-24-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

SMART overall-health self-assessment test result: PASSED

sudo smartctl -A /dev/sda 
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.13.0-24-generic] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

SMART Attributes Data Structure revision number: 1
Vendor Specific SMART Attributes with Thresholds:
5 Reallocated_Sector_Ct   0x0033   100   100   010    Pre-fail  Always       -       0
9 Power_On_Hours          0x0032   099   099   000    Old_age   Always       -       2869
12 Power_Cycle_Count       0x0032   098   098   000    Old_age   Always       -       1836
177 Wear_Leveling_Count     0x0013   098   098   000    Pre-fail  Always       -       48
179 Used_Rsvd_Blk_Cnt_Tot   0x0013   100   100   010    Pre-fail  Always       -       0
181 Program_Fail_Cnt_Total  0x0032   100   100   010    Old_age   Always       -       0
182 Erase_Fail_Count_Total  0x0032   100   100   010    Old_age   Always       -       0
183 Runtime_Bad_Block       0x0013   100   100   010    Pre-fail  Always       -       0
187 Uncorrectable_Error_Cnt 0x0032   100   100   000    Old_age   Always       -       0
190 Airflow_Temperature_Cel 0x0032   062   050   000    Old_age   Always       -       38
195 ECC_Error_Rate          0x001a   200   200   000    Old_age   Always       -       0
199 CRC_Error_Count         0x003e   253   253   000    Old_age   Always       -       0
235 POR_Recovery_Count      0x0012   099   099   000    Old_age   Always       -       128
241 Total_LBAs_Written      0x0032   099   099   000    Old_age   Always       -       6450810314

My question

How to recover my /boot-partition? I think that it's broken is causing the whole issue.
What is wrong with my /boot-partition and how could this happen? My whole productive OS is broken and I would like to know how to avoid this in the future.

Any help is highly appreciated!

  • 1
    "No space left on device" - so is /boot full? You show errors on signed version but update uses unsigned and another error is on an old 3.11 version. Check how fill partition is. – oldfred May 14 '14 at 14:30
  • @oldfred /boot has 57.8MB of 247.8 MB free. I guess that's enough isnt' it? I cleaned the kernels before the error occured, so I think the "no space left error" is because of the broken file system. I cannot comment on the signed / unsigned issue. What's the difference? The nautilus error is triggered by the version 3.11. in my /boot partition, the initramfs error is triggered by the updated 3.13 version. I think that does make sense. – Joshua Gleitze May 14 '14 at 17:04

"Input/output error" indicates a reading/writing error, possibly caused by a disk defect. It seems not being able to read/write blocks, and so it can't modify the partition.

I recommend backing up all your personal data on the disk and checking the filesystem with a tool of your choice.

-- Update --

for filesystem-check you could use

fsck.ext2 -p -f -C0 /dev/sda2

It will check the filesystem (-f), give you some information what's going on, show a progress bar (-C0) and ask you, whether it should try to fix major problems (-p).

If you got a lot of problems, I'd advise to install


and run

sudo smartctl -H /dev/sda 

for a fast test

sudo smartctl -t long /dev/sda 

check the hard disk thoroughly

sudo smartctl -a /dev/sda 

to show hard disk state

sudo smartctl -A /dev/sda 

to show hard disk attributes.

  • I really hope that this is not a hardware issue, as I'm running a one and a half year old Samsung SSD. – Joshua Gleitze May 14 '14 at 14:07
  • Thanks for your help, how would you recommend to check / fix the file system? – Joshua Gleitze May 14 '14 at 14:08
  • @zoig: welcome to ask ubuntu. While it is correct, this answer would be more useful if you describe how to check the filesystem. – David Oneill May 14 '14 at 14:12
  • I ran the tests, you can see the first results above. – Joshua Gleitze May 14 '14 at 17:29

I'm back in!

Using fsck.ext2 really made the deal. After sudo fsck.ext2 -f -C0 /dev/sda2 and answering everything with "yes" (see in the question) the filesystem was fixed.

After that I unlocked my encrypted partition, mounted everything and chrooted into my system. There, I ran apt-get dist-upgrade. After that, grub went into the grub command line on startup.

I went back into the live system and ran boot-repair afterwards. After that I had to reconfigure my encryption setup, see EncryptedFilesystemsViaUbiquity.

Now, I am able to use my system again. The network is somehow broken, it connects nicely but I cannot use the internet in programs. sudo dhclient wlan0 fixes this for one session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.