0

my wifi works but is very slow and I have constant interruptions. I get in /var/log/syslog

kernel: [ 2125.408367] brcmfmac: brcmf_escan_timeout: timer expired

nm-tool: nm-tool

NetworkManager Tool

State: connected (global)

  • Device: wlan0 [HNET] -------------------------------------------------------- Type: 802.11 WiFi Driver: brcmfmac_sdio State: connected Default: yes HW Address: XXXXXXXXXXX (hidden)

    Capabilities: Speed: 11 Mb/s

    Wireless Properties WEP Encryption: yes WPA Encryption: yes WPA2 Encryption: yes

    Wireless Access Points (* = current AP) *HNET: Infra,XXXXXXXXXXXXXXXXXX, Freq 2437 MHz, Rate 54 Mb/s, Strength 39 ZWGLBDATA: Infra, XXXXXXXXXXXXXXXXX, Freq 2437 MHz, Rate 54 Mb/s, Strength 30 WPA WPA2 Enterprise

    IPv4 Settings: Address: 10.1.82.179 Prefix: 19 (255.255.224.0) Gateway: 10.1.64.1

    DNS: 10.1.64.1

can somebody help?

  • Odd. I also got a Vaio Pro 13, and although I also have issues with my Wifi, my computer uses iwlwifi. Could you post a lspsci? – Daniel Holm May 15 '14 at 19:20
  • You're relatively lucky, I've got one which won't even connect to a successfully scanned network; the search hints that nvram file is quite platform-specific (and this is the reason it's not generally shipped), try looking for other brcmfmac43241b4-sdio.txt variants but do back up what you already have (probably as /lib/firmware/brcm/brcmfmac43241b4-sdio.txt). Might be useful either: wireless.kernel.org/en/users/Drivers/brcm80211 – Michael Shigorin Nov 11 '14 at 17:32
0

Try this:

Edit your iwlwifi.conf

nano /etc/modprobe.d/iwlwifi.conf

Comment the last three lines and add this:

options iwlwifi bt_coex_active=0 power_save=1

Your file should end like this:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
#remove iwlwifi \
#(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
#&& /sbin/modprobe -r mac80211
options iwlwifi bt_coex_active=0 power_save=1

Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.