0

I'm quite new to Ubuntu so please be precise.

In my college, I've specific Wi-Fi settings with username and password, as well as LAN settings with proxy server.

In my Network Settings and in the preference of Firefox, I've given the desired settings and so my Wi-Fi works, but my terminal can't connect to WiFi.

I tried yum install and even ping www.google.com in my terminal but yet it can't connect.

but when I open the ubuntu repository (http://in.archive.ubuntu.com/) in my firefox browser it opens up the webpage.

So how can I get around this problem ?

My college's ITadmin staff won't help with this problem.

So how shall I configure my terminal to connect to the internet?

At my house, where I don't have this settings, there the terminal connects to the internet.

after I do

export | grep proxy

I get the output as

declare -x ftp_proxy="http://myusername:password@10.30.1.252:8080"

declare -x http_proxy="http://myusername:password@10.30.1.252:8080"

declare -x https_proxy="http://myusername:password@10.30.1.252:8080"

and if I do

wget www.google.com

I get the output as

--2014-05-15 11:09:12-- http://www.google.com/

Connecting to 10.30.1.252:8080... connected.

Proxy request sent, awaiting response... 407 Proxy Authentication Required ( Forefront TMG requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )

2014-05-15 11:09:12 ERROR 407: Proxy Authentication Required ( Forefront TMG requires authorization to fulfill the request. Access to the Web Proxy filter is denied. ).

Please help!!

2

1.: Check the proxy settings in Firefox: Edit - Preferences - Advanced - Network - Settings...

Here should be proxy settings

If not then check proxy in Network settings

2.

sudo nano /etc/environment

3.: type your sudo password

4.: add these lines:

  http_proxy=http://your-proxy-goes-here
  https_proxy=http://your-proxy-goes-here
  ftp_proxy=http://your-proxy-goes-here

5.: Ctrl+X , confirm same name and press Y to confirm again (It will guide you)

6.: run from new terminal

 sudo +E apt-get update

should do the trick

0

The terminal doesn't connect to the internet. Your computer does, and your terminal makes use of it. You could try to execute wget http://google.com/. If you don't get any errors everything is working.

It could be that your college's proxy is blocking everything but http. If you want to use other protocols you'll have to use a VPN that can be reached over port 80 TCP (the http port).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.