My Ubuntu's Firefox browser's sub menus disappears after the screen saver is active. When I click on a menu topic like 'File' the sub menu appears, but when I move the mouse to select a menu item, the sub menu disappears. I tried to disable the display hardware acceleration property, but it did not help.

closed as too localized by Bruno Pereira Mar 6 '12 at 8:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

migrated from stackoverflow.com Jun 2 '11 at 12:18

This question came from our site for professional and enthusiast programmers.

  • By the way, this happens on all the computers running Ubuntu 11.04 I've tried (about 6). – Alin Andrei Jun 2 '11 at 13:57

I don't know why this happens (it happens to me too), but if you minimize Firefox and then maximize it again, the problem will go away.


It seems to be a problem with X11

Did you tried to replace compiz?

compiz --replace

  • that would be 'nice' (sic) advise if his graphics card doesn't support compiz in the first place :) now that is inceasingly unlikely nowadays, BUT we are talking about a user who is experiencing display trouble to begin with! – sehe Jun 2 '11 at 11:02