Version - Ubuntu 14.04 (also tried 13.10 and 12.10)

Machine - Lenovo R61e (Laptop)

I have been unable to determine what the problem is and I'm really hoping someone here has some suggestions.


  • (in any text-input or word program) I press a key on the built-in Keyboard
  • Nothing happens for a period of time
  • After a delay, the key will input repeatedly, as if stuck or held down
  • I move the mouse and it stops
  • I press a key and then immediately move the mouse
  • The key will input properly without repeating, but only after the mouse movement
  • I plug in a USB (or wireless) Keyboard
  • Keyboard inputs properly; no problems

I am stuck between thinking this is a hardware issue (which I doubt, due to no issues previously on Windows XP) and a driver issue (which I have no idea how to troubleshoot).

Does this make sense to anyone else? Anything I can try to help narrow down the problem?

  • Here is a similar problem
    – Mr.Lee
    May 14, 2014 at 5:04
  • ^ suggests creating a new keyboard from scratch. I deleted and set up from scratch 3 times - still no success.
    – hunter_pdx
    May 19, 2014 at 21:53

1 Answer 1


Could you please try to check Keyboard - System Settings with Keyboard Repeat parameter, it may be sometimes helpful to turn it off and on again. Then please also check the Delay and Rate parameters. I have 660ms of delay and 25.00 repeats Rate by default.

  • I've toggled "Repeat Keys" off and on, tried with it off and numerous levels of delay/speed. Doesn't seem to make a difference. Additional detail noted: keyboard works fine in BIOS.
    – hunter_pdx
    May 16, 2014 at 16:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .