I'm afraid this is another question about Broadcom wifi (in particular, the BCM4313 chipset). Before upgrading to 14.04, my wifi worked perfectly. Since upgrading, it has been working only very slowly, and occasionally not at all.

I am currently running the brcmsmac driver, which the official documentation, as well as many of the answers in the links below, suggest is the right one for my kernel version and chipset.

I have pasted the wireless info from my computer (including lspci, iwconfig, iwlist, lsmod, etc.) here: http://pastebin.com/5fhWiWi0.

I appreciate that problems such as mine seem to be widespread. Here are some of the similar questions I've found on these forums:

However, none of the answers contained therein worked/applied in my case.

EDIT: I should have mentioned that I have also tried using bcmwl-kernel-source. This works better than bcrcmsmac (but not perfectly) on one of the two wifi networks that I regularly use, but it won't even allow me to connect to the other one.

  • Try with sudo apt-get --reinstall install linux-firmware-nonfree. This is the common wifi driver containing package. – user224082 May 14 '14 at 3:01
  • Done. Unfortunately no difference to the connection. – paul May 14 '14 at 3:20
  • If so, install the broadcom b43 driver installer and install drivers from it. sudo apt-get install firmware-b43-installer – user224082 May 14 '14 at 4:15
  • This doesn't seem to work at all (it won't even connect). – paul May 14 '14 at 12:36

Yes, I was having same issue with brcmsmac drivers.

I installed as given in the screenshot below.Use synaptic and type broadcom in search box Do not use jockey-gtk, it will fail to load there.

Install it in this way,

Reboot and your problem will be resolved. I was using 12.04 earlier and these proprietary drivers were not working there. But in 14.04 they are working flawlessly. If failed, try to install again as per broadcom documentation.


Read in last lines

From the GUI:

Package Manager (System>Administration>Synaptic Package Manager). Click the Reload button in the upper left corner of Synaptic to refresh your index then search for and reinstall the package named bcmwl-kernel-source.

From the shell: sudo apt-get update sudo apt-get --reinstall install bcmwl-kernel-source

  • Many thanks @Kanhinya. Apologies, I should have said in my original post that I've tried the bcmwl-kernel-source driver and that doesn't work for me either. I've amended the question accordingly. – paul May 14 '14 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.