0

I've known since shortly after starting with various flavors of *nix circa '04 that the OS is multi-user server environment. There remains a nagging issue that I just can't seem wrap my head around, and I'd like to solve it. Given that on effectively any virtual infrastructure (whether I own it or not) I can spin up this multi-user environment with relative ease and connect to it securely (as I can), and given that I can install and securely deliver applications at no additional cost per application via ssh command line, why is complete, open delivery of a desktop environment such a pain?

VDI solutions exist, but are nearly all geared towards Windows; this makes sense given that the Windows environment wasn't designed with multiple users in mind. Such tools that support linux exist, but are far less prevalent.

Furthermore, solutions seem to exist within the current scope of *nix OSs and Ubuntu specifically via LTSP, but when put into a public space (remote server), LTSP (to my knowledge) breaks down.

Getting to the question (this isn't a rant thread; I'm just frustrated because I haven't yet found a solution to this issue), is there a way to deliver a full desktop experience (sound, video, something skype-ish) via remote Ubuntu Server to a local Ubuntu client (I'll worry about other platforms later) that doesn't involve software costs?

Here's what I've tried so far:

Ubuntu 12.04 and Ubuntu 14.04 (desktop and server) using LXDE delivered via xrdp -> everything works wonderfully, except for sound. Ubuntu 12.04 and Ubuntu 14.04 (desktop and server) gnome-session-fallback via freenx -> mixed results: 12.04 worked fairly well and I'm still working on that [video only, so far], 14.04 was a total bust: the only that works is an ssh prompt. Ubuntu 12.04 and Ubuntu 14.04 (desktop) applications deliverd ssh + x -> works, except for sound Ubuntu 12.04 and Ubuntu 14.04 (desktop) desktop delivered via xephyr -> remote screens blank

Any help is appreciated.

  • Well, working with a few people on the Ubuntu Forums, I was able to get a solution working, but it uses x2go instead of xrdp. Full details on the install process and client options, at least as far I have yet gone can be found at [link]ubuntuforums.org/showthread.php?t=2223938&page=2 – Matt Fussell Jun 2 '14 at 18:27
1

Well, working with a few people on the Ubuntu Forums, I was able to get a solution working, but it uses x2go instead of xrdp.

First install openssh-server:

sudo apt-get install openssh-server

You need to modify the sshd_config file, so make a backup

sudo cp /etc/shh/sshd_config /etc/ssh/sshd_config.back

open the file

sudoedit /etc/ssh/sshd_config

find these lines

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

and change that last no to yes

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication yes

Find these lines

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

And uncomment like so:

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

Now restart the service

sudo service sshd restart

Now install x2go from ppa on the server

sudo add-apt-repository ppa:x2go/stable
sudo apt-get update
sudo apt-get install -y lxde alsa pulseaudio paprefs x2goserver x2goserver-xsession
sudo apt-get autoremove -y
sudo apt-get clean

Add yourself to the x2gouser group

sudo adduser $USER x2gouser

On the client install the client package and paprefs

sudo add-apt-repository ppa:x2go/stable
sudo apt-get update
sudo apt-get install paprefs x2goclient

In order to login to your remote server, start the x2go program and put in the IP address (or URL if you have one) and your username. Make any other configuration changes that need to be done, and then go back to the tab with your username. Instead of selecting LXDE as the session type, select custom desktop. In the field next to this selector, enter:

ck-launch-session startlxde

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.