2

I'm using gnome 3.10 on ubuntu 14.04, with gdm as my default login manager. Also, numix-gtk-theme and numix circle icon pack.

For whatever reason, sometimes my system stops detecting wifi (even if it's already connected) and I can only reconnect upon rebooting. After one of those reboots, I logged in, but was presented with the grayish gdm background, without no further actions. All I could do (and I've done this extensively since then) was Ctrl + Alt + F1 and try some stuff out.

After some research, I noticed that:

  • startx worked at that particular session, but it was rather slow;
  • reinstalling, reconfiguring, both gdm and gnome-shell would do nothing;
  • the only thing that seemed to fix my problem was renaming /.config/dconf; after rebooting, it worked. Just now, though, I had to reboot again and the same problem happened.
  • I just tried adding a new user. It worked within the new user, but then I don't have any of the stuff I installed there.

Any thoughts? If you need further info, let me know and I'll edit accordingly.

  • Try How do I reset GNOME to the defaults? – bain May 13 '14 at 23:55
  • By now I've refined the source of the problem. It seems to be related to a side effect of using variety. It's causing some visual component to be stuck at load, but I can't identify which. Right after I install variety, it "compromises" my dconf; I delete it and reboot; it works; variety does its thing again; problem happens again. (I know it's variety's fault because after I got all my settings turned on but uninstalled it, everything went fine. Did multiple tests to confirm.). But, man, I want to use it. – radgeRayden May 14 '14 at 2:35
  • 2
    Author of Variety here. You may report this as bug at bugs.launchpad.net/variety. Here are some things to try: 1. Uncheck the option to change wallpaper on start in Variety, if it is checked. Check if this fixes the problem. 2. Edit the file ~/.config/variety/scripts/set_wallpaper - this is the script that runs on every wallpaper change. Comment out all lines that are not applicable for your system - e.g. sections for XFCE, Lubuntu, etc. – Peter Levi May 15 '14 at 13:04
  • Variety generally runs on a fairly high level and does nothing to cause the symptoms you describe. The only system setting it "touches" is the path to the wallpaper image. Just having it installed, and not running it has no side consequences, and it definitely does not "compromise" dconf. But what you see might be some side effect of the wallpaper being changed in some unfortunate moment during startup, e.g. compiz loading the CPU/GPU, causing some race condition in a completely different process, etc. If the suggestions above make a difference, please make sure to report back. Thanks. – Peter Levi May 15 '14 at 13:06
  • Peter, I'm glad you answered. Seem like a great dev. I actually fixed it, will answer with solution. – radgeRayden May 16 '14 at 2:19
3

It seems I've solved the problem. After a lot of tinkering and resetting my dconf several times, I started to look closely and noticed several things.

Although I don't have the logs (.bash_history doesn't save output, only input), what I know is that I used to receive something along

perl: couldn't find your locale. Falling back to "C"

when reinstalling variety.

which I ignored, since my system was already working with the language I'd chosen (despite not being fully translated, it was indeed set to pt_BR). I searched about it and reconfigured my locale several times - it didn't worked. Then, I realized I didn't even have my language pack installed. After reinstalling it, everything worked (even with changing at start enabled).

Yes, I know: it's really unrelated (it was my fault after all), but if it causes a complete failure for gnome, I think it should get an workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.