2

Not booting

Running Ubuntu on my T430 has been fairly straightforward and great until just now. After I used my Windows for some days, Ubuntu all of a sudden fails to boot. After I select Ubuntu in GRUB, I get the following screen:

Error: File "/vmlinuz-3.13.0.24-generic.efi.signed" not found  
unalinged pointer to 0xd0a26c68  
Aborted. Press any key to exit.

Error: File "/vmlinuz-3.13.0.24-generic.efi.signed" not found  unalinged pointer to 0xd0a26c68

Neiter does a live system

To fix that, I tried to launch a live Ubuntu to do things like update the packages and reinstall grub. But the live Ubuntu failed to boot as well, it only gave me the GRUB command line. Unfortunately, I don't know what to do with it.

GRUB command line

What now?

I have no idea where a problem like this could come from. In Windows, Lenovo showed a UEFI-Update wich I thought I had deselected, but it might just have slipped in. Anyway, can a problem like this be triggered by a updated UEFI?

Starting in recovery mode doesn't help. I cleaned old kernels to have space on my /boot - partition again so I cannot try older kernels. Until now, the current kernel just worked for me.

As I don't have a OS I can work with in the moment I would be very grateful for any tips, hints or suggestions.

10
  • Sorry I'm unfamiliar with the Lenovo, but it seems like it may be a BIOS setting, in the boot section - or perhaps you now need the EFI kernel (I don't have that on mine). I recently got a new motherboard for my desktop, and the UEFI seems a bit confusing; it seems that I have two choices for disks and USB boot devices (I assume legacy). If I choose UEFI, it won't boot the USB. Perhaps you can look at all the choices in the boot section to see if you can change something. Just remember what you change in case Windows doesn't work. – Marty Fried May 13 '14 at 17:07
  • 1
    @MartyFried: Thanks a lot for your help! My machine has always had UEFI with the UEFI-mode set to UEFI & Legacy. Secure Boot is disabled. Funny enough, I need this configuration to run my windows, Ubuntu works fine regardless how I configure these settings. Apart from that, I was not able to find any UEFI-settings that have changed or that I think could trigger ths problem. – Joshua Gleitze May 13 '14 at 17:15
  • @MartyFried I tried once again and found out the following: (my testing was obvisiouly not good enough): In Legacy boot mode, neither my ubuntu installation nor the USB will start (selecting them in the boot menu just does nothing) Windows won't work in UEFI mode. I don't know how I managed to have such a bad configuration, but there were some reasons. That's why I use UEFI & Legacy boot mode. – Joshua Gleitze May 13 '14 at 17:28
  • I don't have Windows, so my setup is easier. I disabled secure boot, and I leave it in the UEFI + legacy mode also. However, my problems were in a different place, where you choose the disk to boot from. There were two choices in one place for each, and another place only had one, depending on which was chosen in the first one (boot order, I believe). I didn't really know what I was doing, and was too impatient to research it, so I just tried a few things until it worked. Anyway, the mode was per device, not global. Sorry I can't be more specific. – Marty Fried May 13 '14 at 17:35
  • I don't think this applies to me here. I photographed three screens of my UEFI configuration that seemed relevant to me, even though I don't know how this settings could affect the problem. See: dl.dropboxusercontent.com/u/11156172/IMAG0227%5B1%5D.jpg, dl.dropboxusercontent.com/u/11156172/IMAG0228%5B1%5D.jpg, dl.dropboxusercontent.com/u/11156172/IMAG0229%5B1%5D.jpg – Joshua Gleitze May 13 '14 at 17:45
1

The problem with the USB was obviously a broken ISO. My bad, I should have checked better. So the live system is working now.

With the live system, I got new information and the issue seems to be more about my /boot-partition than my UEFI. As I didn't want to essentially edit the whole question, I opened a new one.

I want to thank @MartyFried a lot for his help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.