2

I'm using Oracle VM VirtualBox Manager 4.3.10_Ubuntu as a Virtualization solution.

I've installed Windows 8.1 x64 for some usb devices that Linux does not have compatible software (Polar Pro Training 5).

At first i could not see any actions when selected on Virtualbox side. After adding my username with sudo adduser yourusername vboxusers command Windows recognized all usb devices plugged in. But at the "Device Manager" tab, there is a exclamation mark. Although Windows try to install drivers for the usb nothing happens. This occur for all usb devices. Here is screen shots of my device manager.

Windows side: image

Ubuntu Virtualbox parameters: ubuntu

  • For full USB2.0 support you may need the Oracle Extension Pack: askubuntu.com/questions/41478/… – Takkat May 13 '14 at 11:26
  • Although installed Oracle Extension Pack after your recommendation did not work. – akikara May 13 '14 at 12:13
  • After installing "Oracle Extension Pack" i noticed that the port i was using is usb 3.0. Switched USB stick to USB 2.0 port and worked. – akikara May 13 '14 at 12:16
  • yeah - USB3.0 is not yet supported in virtualbox... consider to write this in an own answer to your question to help other people who may come here. – Takkat May 13 '14 at 12:58
3

For Ubuntu 14.04 default VirtualBox package version (4.3.10) USB 2.0 support is integrated but there is still no USB 3.0 support. Consider this while trying to use your USB ports.

For adding specific USB devices to your VirtualBox's guest you need to add your user to vboxusers group via sudo adduser yourusername vboxusers

If you plug your device to an USB 3.0 port of your PC, Laptop etc. a Windows guest will then give this error:

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.