I have tried to use fglrx proprietary driver for ATI Radeon HD 5670 in Ubuntu 14.04 but when I install it (using either apt-get or the "Additional Drivers" tab in "Software & Updates" application) I get a blank screen in the next reboot instead of the login screen.

I have 2 GPUs working in "dual" mode (Crossfire).

I have tried both fglrx and fglrx-updates with the same result for both.

I followed all the steps in the Help Wiki but same problem persists.

Output of grep "] (EE)" /var/log/Xorg.0.log:

[    10.550] (EE) open /dev/dri/card0: No such file or directory
[    10.769] (EE) AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
[    10.769] (EE) AIGLX error: failed to open /usr/lib64/dri/fglrx_dri.so, error[/usr/lib64/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
[    10.769] (EE) AIGLX error: failed to open /usr/X11R6/lib/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]

I also tried:

  • setting nomodeset parameter at boot

  • ln -s /usr/lib /usr/lib64

but problem persists.

  • +1, well written question. I have a similar card in my Samsung laptop --- I never managed to have the proprietary drivers work.
    – Rmano
    May 15 '14 at 15:09

(start rant) I post my solution here if someone stumbles on the same quite annoying issue. This bug has many implications for the efficient running of your Trusty Tahr desktop. If you work at Ubuntu, I am very perplexed as to why your team won't solve this. Many people have this issue, and your LTS, an otherwise fine release, is atrociously slow, unstable and buggy for this issue. (end rant)

This fix for me, it meant better --- no, strike that--- usable --- running of the browsers we all commonly use--firefox and/or chrome.

Follow instructions in this page and install the linux-headers-generic and fglrx-updates and fglrx-amdcccle-updates. Then, you run in to the errors stated in this original question. At this point, you are ready for the simple fix (notwithstanding the fact that it took a week for me to get here-obviously, the fix is obvious once it is stated simply):

sudo ln -s /usr/lib /usr/lib64
sudo mkdir -p /usr/X11R6/lib64/modules/dri/
sudo ln -s /usr/lib/dri/fglrx_dri.so /usr/X11R6/lib64/modules/dri/fglrx_dri.so 

When you are done, you should be able to check the following:

root@mysillymachine:/usr/X11R6/lib64/modules/dri# ls -liat
total 8
4198453 drwxr-xr-x 2 root root 4096 Aug 27 10:19 .
4198454 lrwxrwxrwx 1 root root   25 Aug 27 10:19 fglrx_dri.so ->  /usr/lib/dri/fglrx_dri.so
4198452 drwxr-xr-x 3 root root 4096 Aug 27 10:19 ..
  • 1
    I already have a /usr/lib64 directory (containing only a gconv directory) so I cannot run the first command. Any alternative? And, by the way, it looks like the forth command should be the reverse: ln -s /usr/lib/dri/fglrx_dri.so fglrx_dri.so
    – Óscar
    Sep 4 '14 at 19:06
  • I've had troubles for as long as I can remember with the Catalyst driver and changing users. Changing user once always work, but upon changing back the screen goes black and the system appears to stop. I've been able to go around this by switching VT to 7 and 8. However, I stumbled across the AIGLX error in the apport report and I symlinked fglrx_dri.so as Sonny suggested. That seems to work for me! Running A10-7800 APU, Radeon R7.
    – fohswe
    Dec 9 '14 at 19:12

(EE) open /dev/dri/card0: No such file or directory indicates that the kernel module for the card isn't loaded. The possible scenarios I see are that either your card isn't supported anymore (in which case the opensource driver is a good alternative with very good performance) or that the driver couldn't be built correctly on installation.

Make sure your have the package linux-headers-generic installed and reinstall your drivers.

After installing the drivers through the Additional Drivers tab, run sudo aticonfig --initial -f in a terminal and reboot your machine.

  • Yes, I tried that too, in fact I followed all the steps here, and same result: help.ubuntu.com/community/BinaryDriverHowto/…
    – Óscar
    May 13 '14 at 11:23
  • Can you please post the output of grep "] (EE)" /var/log/Xorg.0.log
    – mniess
    May 13 '14 at 11:28
  • I have updated the question with this info, thanks!
    – Óscar
    May 13 '14 at 11:41
  • The problem with the open source driver is that the computer is more noisy because of the video card fans working more. I do have linux-headers-generic installed and my cards (two Crossfire ATI Radeon HD 5670) are supported by AMD propietary driver according to the driver release notes: support.amd.com/en-us/kb-articles/Pages/…
    – Óscar
    May 14 '14 at 8:01
  • Can you try booting Ubuntu without kernel modesetting. You do this by selecting the Ubuntu entry in GRUB and then pressing "e" to (temporarily) edit the boot parameters. In the linux line append nomodeset. If it works, see the link above on how to make it permanent.
    – mniess
    May 14 '14 at 10:33
sudo ln -s /usr/lib /usr/lib64
sudo mkdir -p /usr/X11R6/lib64/modules/dri/
sudo ln -s /usr/lib/dri/fglrx_dri.so /usr/X11R6/lib64/modules/dri/fglrx_dri.so 
cd /usr/X11R6/lib64/modules/dri/

myuser@ubuntu:/usr/X11R6/lib64/modules/dri$ ls -ltr
total 0
lrwxrwxrwx 1 root root 25 Abr  4 12:37 fglrx_dri.so -> /usr/lib/dri/fglrx_dri.so

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.