0

I just installed ubuntu server 14.04 LTS, overwriting 12.04.

The installation appears to proceed correctly. During the installation process the IP and hostname are correctly obtained via dhcp. However, when installation completes and the machine reboots (removing the disc from the drive), the selected interface, eth0 does not obtain the IP.

Performing sudo ifdown eth0 && sudo ifup eth0 and sudo dhclient -v eth0 both result in a bunch of DHCPDISCOVER messages and errors with:

No DHCPOFFERS received.
No working leases in persistent database

/etc/network/interfaces (untouched following fresh installation)

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

The interface and cable were working fine with the previous ubuntu server 12.04 installation. Any ideas on what to do? This is a fresh install, and doesn't obtain the IP immediately after the reboot initial reboot.

3

Try setting the IP manually and see if it works. sudo ifconfig eth0 you.ip.address.here netmask netmask.goes.in.here then try pinging the router.

0

Ok this was weird and probably a bug.

This machine has 2 interfaces (one broadcom and one intel), with only the broadcom interface plugged in. During the installation phase I tried both to check which was plugged in, eth0 (broadcom) and eth1 (intel). Selecting eth0 successfully obtained the IP via dhcp, and as expected eth1 failed.

I proceeded through the 14.04 installation process using eth0. At initial reboot and load, eth0 failed to obtain the IP via DHCP on boot. I performed the troubleshooting listed in the question with no luck getting the interface up.

However, after checking dmesg | grep eth0, I noticed that it listed Intel and not the expected broadcom. I switched the cables, and sure enough, eth0 had been switched from the boardcom interface selected during installation.

Very strange. This did not happen with 12.04 on the same machine. (Not sure if this means anything but now in ifconfig -a the second interface is no longer listed)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.