3

I have installed Eclipse as following:

1 → Download eclipse-standard-kepler-SR2-linux-gtk-x86_64.tar.gz to my 14.04

enter image description here

2 → Extracted it using the command,

sudo tar -xvf eclipse-standard-kepler-SR2-linux-gtk-x86_64.tar.gz

3 → Moved eclipse to /opt/ using command,

sudo mv eclipse /opt/

4 → Created Icon(64x64) for eclipse using GIMP Image Editor.

5 → Installed gnome-panel using,

sudo apt-get install --no-install-recommends gnome-panel

6 → And Create Application by using,

sudo gnome-desktop-item-edit /usr/share/applications/ --create-new

img1

7 → Select Icon,

img3

8 → Select eclipse application for comment,

enter image description here

9 → Finally enter command and click OK.

enter image description here

I have given everything required, and the application created and showing,

enter image description here

But when I open this application it's not working.

(Note: I have created another one, because first one not worked, and now both not working. That why picture showing two eclipse.)

When I tried to open it in terminal, I got

bash: /opt/eclipse/eclipse: cannot execute binary file: Exec format error

Please tell me where the problem may occur ?

  • BTW you downloaded Kepler but called it Juno in shortcut. It might take displeasure =) – Danatela May 14 '14 at 11:58
9

If you get

/opt/eclipse/eclipse: cannot execute binary file: Exec format error

that usually means you use the wrong architecture. In this case you downloaded the 64bit version but should use the 32bit version of Eclipse.

|improve this answer|||||
  • thank you friend.. lately I found that.. when I came here to post.. I saw your post.. thanks again.. – A J May 14 '14 at 11:18
  • use linux file utility to check architecture of the file: stackoverflow.com/a/2902650/304285 – amra Jul 10 '14 at 9:30
1

when I tried to open in terminal, am getting bash: /opt/eclipse/eclipse: cannot execute binary file: Exec format error

That means the file is damaged. Perhaps something went wrong while you did extraction. To ensure that it's not archive problem, follow these instructions:

  1. Every download has an associated link "(md5)" to a *.md5 file containing its MD5 checksum. Download this file into the same directory as the appropriate tar.gz file.

  2. Execute the command md5sum -c <gzfilename>.md5. The result <gzfilename>: OK is indicative of an intact download.

If the check succeeds, you have to remove Eclipse (sudo rm -rf /opt/eclipse) and repeat the steps you mentioned. If not, you have to redownload the file.

|improve this answer|||||
  • am getting the same error again.. – A J May 13 '14 at 9:49
  • Please run ls -l /opt/eclipse/eclipse and show the output. – Danatela May 13 '14 at 9:54
  • the result is, -rwxr-xr-x 1 messagebus users 73031 Jan 16 04:44 /opt/eclipse/eclipse – A J May 13 '14 at 9:56
  • I have fix the problem.. it was stupid, I download 64-bit instead of 32-bit... thank you so much – A J May 14 '14 at 11:16
  • Ugh... I'm stupid too =) Please upvote the answer you accepted. – Danatela May 14 '14 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.