I've tried every suggestion that I've looked at online. My card is a Radeon HD 4250. I've installed fglrx to no avail. After install I just either go into low graphics mode or it will detect my card as VESA: RS880 and none of my games will work that use 3D. I've done terminal install of fglrx and even used AMD's site, both of which do not work. I looked into jockey and Additional Drivers and it shows nothing. I'm not sure what's going on, but my old roommate had it working at one point. I did a fresh install and cannot figure out how to get it back to playing games.

I'd appreciate any help or anyone pointing me in the right direction. As I said, I've tried everything I can search so far and nothing has helped, hence the new question.


AMD has dropped support in their proprietary driver for that card. You have two options:

  1. Uninstall fglrx drivers and use the open source radeon driver (Recommended)
  2. Use the AMD Catalyst Legacy PPA

Note that for (2), your X server will be downgraded to support the older 13.1 fglrx driver. This could lead to other issues and comes with a load of caveats, so read the warnings carefully.

  • Quick question on that: Do I need to manually downgrade my X server or will it be automatic? – user272279 May 13 '14 at 4:51
  • If you use the PPA, I believe it's automatic when you install fglrx-legacy, but again, read the directions and warnings carefully. – mrmagos May 13 '14 at 4:54
  • After install I got: Sorry, a problem occurred while installing software: fglrx-legacy. It gives me no other details. Should I go ahead with a reboot and see what happens or uninstall and try a different method? – user272279 May 13 '14 at 5:00
  • If this is a fresh install of 12.04.3, you should note that fglrx-legacy is not supported; that may be reason for errors. I recommend uninstalling fglrx and fglrx-legacy and trying the open source radeon driver. More info here: help.ubuntu.com/community/RadeonDriver – mrmagos May 13 '14 at 5:04
  • I reverted back to my open source drivers but now it shows "Gallium 0.4 on AMD RS880" and my games are working but extremely laggy. – user272279 May 13 '14 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.