2

I have a kodak digit camera that always has just mounted. Since 14.04, it shows the device itself in lsusb. Looking in syslog I see it recognizes the camera but then fails saying the device is not an mtp. The exact log entries are:

May  9 21:57:12 davelaptop kernel: [ 1733.117649] usb 3-3: new full-speed USB device number 3 using ohci-pci
May  9 21:57:12 davelaptop kernel: [ 1733.316743] usb 3-3: New USB device found, idVendor=040a, idProduct=05d1
May  9 21:57:12 davelaptop kernel: [ 1733.316760] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May  9 21:57:12 davelaptop kernel: [ 1733.316769] usb 3-3: Product: KODAK EASYSHARE C182 Digital Camera
May  9 21:57:12 davelaptop kernel: [ 1733.316778] usb 3-3: Manufacturer: Eastman Kodak Company
May  9 21:57:12 davelaptop kernel: [ 1733.316785] usb 3-3: SerialNumber: C182 020552828
May  9 21:57:12 davelaptop mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:12.0/usb3/3-3"
May  9 21:57:12 davelaptop mtp-probe: bus: 3, device: 3 was not an MTP device
May  9 21:57:12 davelaptop colord: Device added: sysfs-(null)

I also checked in udev and found some entries in hwdb folder about gphoto. It did not have my camera listed. I added it to 2 such rules files in that folder but it still doesn't mount.

My thought - I think something changed in udev and is messing this up. I know there is a process there about probing mtp - perhaps that is failing also/instead?

I see this is not a unique problem. There are lots of posts here and in the ubuntu forums about cameras not mounting. Something is in common - some change from 13.10 to 14.04 is in common.

3

I believe the problem is with mtp-probe which is not able to recognize your camera as Media Transfer Protocol MTP device : mtp-probe: bus: 3, device: 3 was not an MTP device

I have the same problem with my Canon, Inc. Powershot S95 in Ubuntu 14.04 and used gphotofs for a work-around. In a terminal I did the following:

  1. Install gphotofs:
    $ sudo apt-get install gphotofs

  2. then mount your camera, which I did under /tmp/camera
    $ mkdir /tmp/camera/
    $ gphotofs /tmp/camera/

That is it.

If gphotofs worked /tmp/camera/ should now be connected to your camera (check using either the terminal or nautilus). Lastly if you are using a photo manager like shotwell, use an `import from folder' option to access your pictures.

When you are finished importing your pictures you can unmount the camera folder:

$ fusermount -u /tmp/camera/

  • ~> sudo mkdir /media/camera ~> sudo gphotofs /media/camera ~> ls /media/camera ls: cannot access /media/camera: Permission denied ~> ls /media/camera ls: reading directory /media/camera: Protocol error – lrkwz May 12 '15 at 18:05
0

Already had tried that and it didn't work. Also tried several other things including modifying the databases. As it turns out, a recent update fixed the problem - the thread on launchpad explains everything that has been happening to myself and others, and supposedly what the fix is/was.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.