19

Everytime I try to sudo something at the terminal, I get a warning message:

alexandre@XPS-15Z $ sudo mount file.iso /mnt/ -o loop
[sudo] password for alexandre: 
no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory

It's just annoying to get that all the time. How do I solve that? I'm on Ubuntu 14.04 (upgraded from 13.10)

1
37

After a little Googling, I found out this message is related to Samba password syncing.

To fix it, run pam-auth-update and make sure SMB password synchronization is deselected (source). Use space to deselect it.

SMB password synchronization

This should not be necessary when the bug is corrected in SAMBA (in fact, Ubuntu 14.10 is packed with samba 4.1.11 and does not have the same behavior).

3
  • This bug is allegedly corrected in Samba 4.1.10. – Hack Saw Sep 15 '14 at 7:41
  • @HackSaw it still only available through PPA, right? – Alexandre Sep 30 '14 at 16:43
  • As far as I know. For the moment, I'm content to wait, though I hope it gets brought in soon. – Hack Saw Sep 30 '14 at 20:28
0

Another solution that worked better for me was moving to Debian stable release.

My goal is for stability and reliability, and crippling functionality to workaround old reported bugs is not acceptable for a server.

I'm disappointed. A clean install of the latest release of Ubuntu Server 14.04 LTS, and selecting from the install prompt OpenSSH and Samba.

2
  • 1
    That does not solve anything. The answer above is clearly the best answer. – John Scott Jul 27 '14 at 1:18
  • 4
    I can't run Samba with password synchronization disabled. So this is a valid alternate solution. This issue has been reported and tracked over a year. If samba is not going to be supported or updated, it needs to be removed from the ubuntu installer. Also it solves the issue perfectly for me, because debian does not commit bugs and memory leaks into their repository. – user1820024 Jul 27 '14 at 1:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.