126

I am looking for a clean and fast method to force GNOME in Ubuntu 14.04 to switch between active apps only on the current workspace when pressing the shortcut alt + tab.

154

Here is the solution I came up with:

Very fast & easy, without any installations/extensions:

  1. Install dconf-editor (already installed on current debian/ubuntu distributions):

    sudo apt-get install dconf-editor
    
  2. Open dconf-editor (from the Dash or a Terminal)

  3. Navigate to: org -> gnome -> shell -> app-switcher
  4. Set "current-workspace-only" to true

    screenshot

..and you're done :)

  • 8
    Wish Gnome would just put this in their Settings applet – leo-the-manic Dec 28 '16 at 19:29
  • 1
    Please add @austinmarton answer too, since while this is more generic, there's a gnome way that requires no extra installs. – Mihail Malostanidis Oct 7 '17 at 14:54
  • 4
    I've added feature issue to Gnome TWEAK project gitlab.gnome.org/GNOME/gnome-tweaks/issues/123 – sobi3ch Feb 15 '18 at 11:22
  • Wish this will become the default for future release! – samb Mar 10 '18 at 17:58
  • This should be on Gnome Tweak! Agree @sobi3ch – rtindru May 7 '18 at 6:19
146

Simply:

gsettings set org.gnome.shell.app-switcher current-workspace-only true
  • 5
    super fast, no extra software necessary and does exactly what was asked for! +1 – Jamie-505 Mar 3 '17 at 10:52
  • 2
    ...and for me in 17.10. – colan Oct 25 '17 at 15:44
  • 2
    It worked for me too on ubuntu 17.10, and this is the best answer – Marco Oct 26 '17 at 19:22
  • 12
    It's working on Ubuntu 18.04. It's straightforward and you don't need to install anything – Andrea Tulimiero Apr 30 '18 at 20:07
  • 6
    Yup, works on Ubuntu 18.04! – Henrique Ferrolho May 2 '18 at 11:34
15

As an alternative to installing dconf-editor and having to fiddle around with your mouse so much, you can also do this from terminal.

To create the current-workspace-only value:

dconf write /org/gnome/shell/app-switcher/current-workspace-only 'true'

To erase it, going back to default settings:

dconf reset /org/gnome/shell/app-switcher/current-workspace-only

I would like dconf-editor more if it could search through paths, properties, and values.

  • 1
    the (later) answer using gsettings is just a higher-level api that also sets the dconf values (and would probably be in general preferred over directly accessing dconf) – michael Jan 1 '18 at 7:56
8

Seems to be fixed with

gsettings set org.gnome.shell.window-switcher current-workspace-only true
gsettings set org.gnome.shell.app-switcher current-workspace-only true
  • Looks like I need only the first one (.window-switcher) – kerner1000 Jan 5 '18 at 17:52
  • This did the job. It only shows the apps currently in the workspace and, when an app has two instance each in a different workspace when pressing Alt+Tab it prevents from showing both of them. But you have to use both the commands in this answer. Awesome, thank you! – juliangonzalez Oct 1 '18 at 15:38
4

AlternateTab

If you also want to ungroup applications on switcher you can add officially supported AlternateTab extension.

screenshot

Moreover:

Actually, Ubuntu is going to have the Alternatetab as default on Alt+tab in the upcoming version of Ubuntu (19.04), while the current default app switcher will remain on Super+tab.

4

An alternative for people who want to tab through open windows on current workspace but also want to be able to tab through all open apps (on any workspace) this can be achieved by changing the keyboard shortcuts.

Under Settings > Devices > Keyboard (on Ubuntu 17.10):

  • Switch Windows: Alt + Tab
  • Switch Applications: Super + Tab
  • That's tricky - Alt+Tab changes windows, even when changing the keyboard shortcuts. Is there a way to fix that? – Rick-777 Nov 29 '17 at 14:49
  • Yes, Alt+Tab will show the windows open on the current workspace whereas Super+Tab will show all open programs (on any workspace). What do you want to achieve, that Alt+Tab shows open programs on the current workspace instead of open windows? – Clauds Nov 30 '17 at 10:19
  • Hi ! I'm trying to set this specific behavior, but I don't seem to be able to. Both commands always behave the same. I tried gsettings current-workspace-only for window and app switcher with no luck either. Any idea? Thanks :) – Biggybi Apr 15 '18 at 6:16
  • I checked my gsettings and I have org.gnome.shell.app-switcher current-workspace-only false and org.gnome.shell.window-switcher current-workspace-only true – Clauds Apr 15 '18 at 9:59
  • This does not answer the question but is a great tip nonetheless. – crafter Aug 7 '18 at 22:32
1

The other solutions here did not work for me on Ubuntu 18.04.1, but the Alt Tab Workspace extension worked.

protected by N0rbert Sep 20 '18 at 10:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.