0

I have an ASUS X550L. When I try to install ubuntu (any version), my touchpad does not work during the installation and mouse also acts weired such that some buttons cannot be clicked with the mouse. However I installed ubuntu using the keyboard. But my cursor periodically moves to left (about 1cm at once). And also the touchpad does not work either.

What's the problem? Can anybody give me a solution? I have never experienced this issue before in any computer.

Thank you.

3

Just check for the wheel mouse ( Weird that the touchpad is recognized as wheel mouse)

xinput --list

PS/2 Logitech Wheel Mouse id=XX [slave pointer (2)]

if XX is the id number then

xinput --set-prop XX "Device Enabled"  0

Waiting for a fix

Cheers Fuki

1

I just bought this computer and I have exactly the same issue... I search a lot on the internet but only found some bug reports (I have not the links anymore).

Anyway, I tried this :

sudo modprobe -r psmouse

It disables the touchpad driver (if I understood well). The consequences are you can not use your touchpad (strange behavior) and some of the fn functionalities (only volume seems to work). But you can use a USB mouse and the cursor does not move to left by itself.

It is not a solution but it helps me, waiting for an upcoming update (I hope, I use Ubuntu a lot and it is very annoying)

  • Yup. I also tried this using a previous answer. Worked well in disabling the annoying cursor behavior. But couldn't use the touchpad. I had a lot of problems in Ubuntu with my previous laptop. Thought I'd be free after buying the new one. :D – Deepal May 14 '14 at 6:02
  • This is the first touchpad issue I have with Ubuntu (my old laptop was a Sony Vaio, only got problems with graphic card, but on old versions). Also I tried to install Fedora and I got a similar behavior. And the bug reports I read were not about Ubuntu specifically but Linux. So I guess we'll have to wait ! – Anthonin May 14 '14 at 18:41
0

The only solution right now is to use an external mouse.

I also have the same problem with my Asus X450CC under Ubuntu 14.04, but I have not been able to find a solution until now.

I've tried Windows 7 in order to check whether it could be a hardware problem, but the touchpad works correctly with Windows 7.

The best we can do currently is to subscribe to the bug on Launchpad to be notified when something new concerning this issue happens, and provide help in debugging this problem.

  • Yup. Have to wait :) – Deepal May 26 '14 at 14:30
  • 1
    I have taken the time to summarize everything I know about this problem in this blog post: Asus Touchpad not detected under Ubuntu Linux Seems that it's affecting Asus X450CC, X550CA, X550LB, X550LC, X550LD, X750LB – raphaelh Jun 11 '14 at 14:46
0

I tried some solutions mentioned at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1314198/comments/31 . Following is some temporary fix until a proper driver arrives:

  • Make touchpad work in ps/2 mouse emulation mode so that we can use the touchpad but without additional gestures including multi-touch.

  • Type and run the command sudo gedit /etc/default/grub

  • Find the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
  • Add psmouse.proto=bare at the end of the "quiet splash" parameter followed by a space
  • Run sudo update-grub to update
  • Reboot the computer and you'll see touchpad is now working (No guestures/multi-touch though)

Though this is satisfactory, you will find it annoying when you type with your keyboard and your palm touches the touchpad. Mouse pointer will go crazy and some items will get clicked without you knowing. I solved this issue after installing touchpad-indicator. After installing touchpad-indicator I could turn off my touchpad when I use mouse only, and enable touchpad using the mouse when I need to use touchpad. Though this seems to be bit inconvenient, it was useful for me in my case to use both mouse and touchpad at different situations. I currently have no solution to enable/disable touchpad with touchpad-indicator using a keyboard shortcut. Following is how you can install touchpad-indicator.

$ sudo add-apt-repository ppa:atareao/atareao
$ sudo apt-get update
$ sudo apt-get install touchpad-indicator

Important:

touchpad-indicator won't work if you haven't added the kernel parameter psmouse.proto=bare in this case.

Additionally:

After installtion, you can start touchpad-indicator through dash. You can add it to Startup Applications so that it runs at startup everytime. When adding it to startup applications, give the command as /opt/extras.ubuntu.com/touchpad-indicator/bin/touchpad-indicator.

protected by Community Mar 22 '15 at 16:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.