5

I am new to Ubuntu (14.04) and want to type Japanese text. I applied language support "Japanese" and it shows up in the language icon at the page top menue. I installed IBus Input Pad, also Mozc. Both show up at the left hand Starter and the programs can be opened, but the field "apply" is not highlighted. Problem being: the input is simply not working at all. What else do I have to do?

2

I don't know how you get them installed. I first installed mocz from software center and I didn't work. But the following command works. Press Ctrl + Alt + T to start the terminal, then right click on anywhere in the terminal to paste the command:

sudo apt-get install ibus-mozc mozc-server mozc-utils-gui

After everything is done in the terminal, log out once and try find mozc in Text Entry Settings.

Reference: http://inokara.hateblo.jp/entry/2013/03/23/091307

| improve this answer | |
0

I just ran into the same problem and this is a really goofy way to fix it but it worked.

Start terminal and type ibus-setup, which opens up the ibus-preferences. Go to the input method tab and you will be able to add either anthy or mozc from there. The fix is to REMOVE the default "English" from the list so all that remains is the IME you added in the previous step (either anthy or mozc), so the system is forced to use it.

For anthy, by default you can switch between inputting Japanese and inputting English by hitting Ctrl+J.

| improve this answer | |
0

It took me some time to figure this out, but in the input options, you will find something like "English" and "Japanese" (in my case with my Japanese keyboard proper ID'ed during install). However, installing Anthy or Mozc didn't do anything.

You have to go back to the input dialog and add "Japanese-Anthy" or "Japanese-Mozc". Then toggle between them.

By the way, 'Super' button is the "Windows" button.

And if you are having trouble with keyboard layout, the reason is wrong "language" input. For example, when I have "En" selected as input, the keyboard layout is an 'English keyboard layout" In order to type English without any curveballs, I toggle to "Ja" input and get the Japanese layout.

| improve this answer | |
0

What I had to do was install japanese language support using system settings->language support, use system-settings->text entry to add Japanese Anthy and use the Text Entry on the Language dropdown on the panel to select control+space which I am used to.

It took several hours to find the step of adding Japanese Anthy using the system-setings->text. This step was very un-intuitive. I finally found it here and recommend this site for getting anthy Japanese input working.

I expect that using apt-get to install mozc as recommended above and then adding it using system-settings->text entry would add it to the selections but haven't tried it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.