6

I updated handbrake-cli using aptitude upgrade, as well as the codecs and now when I try to convert a file it keeps giving me an error "MP4 muxer disabled". Does any one know what the problem is?

7

Yes. The repo version is broken. I found a comment from the author, I really can't remember where but he acknowledges the official version is no good.

Good news is that he's got a PPA that works well and works flawlessly on my system.

Here's the terminal stuff -

sudo apt-add-repository ppa:stebbins/handbrake-snapshots
sudo apt-get update
sudo apt-get upgrade

He said he'll get it fixed in due course, once he's figured out what went wrong.

| improve this answer | |
  • Confirming this answer, the link for Ubuntu from the HandBrake website points to launchpad.net/~stebbins/+archive/ubuntu/handbrake-releases – Von Sep 10 '14 at 1:03
  • Go careful here, there are two repos from Stebbins. *-releases are the stable Ubuntu versions which have not worked in the past, and seem to be the same as the one in the Ubuntu offical repos. The *-snapshots PPA I mentioned above is known to work and is the one I use consistently. – Drac Noc Dec 23 '14 at 17:16
  • I'm going to add an amendment here. The Stebbins PPA/handbrake-releases are now working fine and I have changed from the nightly *snapshots as they can be unstable from time to time. – Drac Noc May 14 '15 at 5:27
3

Just sudo apt-get upgrade didnt do it for me. Needed to run sudo apt-get upgrade handbrake-cli to get it actually upgraded (or downgraded?).

| improve this answer | |
  • Thank you! The same applied to me in Ubuntu Server 14.04 – Lalo Sánchez Mar 7 '16 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.