I don't like, need nor want the notification bubbles which pop up in the top right corner of the screen. I've looked around quite a bit but can't identify how to disable them?

NotifyOSD Configuration let's me change the look of them, but not get rid of them. Can anyone help?


  • Could you add the output of grep -r -i org.freedesktop.Notifications /usr/share/dbus-1/services/ & ps ax | grep -i notif
    – user.dz
    Sep 15, 2014 at 5:31
  • 1
    possible duplicate of How can I customize/disable notification bubbles?
    – muru
    Apr 12, 2015 at 9:42
  • Hi @Empty , did you notice you have a new answer? Since you edited your question, I assumed you were looking for one, wrong assumption? Jan 5, 2016 at 20:14
  • ubuntu is such a lame sometimes.
    – r3wt
    Apr 5, 2016 at 2:53

3 Answers 3


To completely turn off notifications, open a Terminal (Ctrl+Alt+T) and type the following command:

sudo mv /usr/share/dbus-1/services/org.freedesktop.Notifications.service /usr/share/dbus-1/services/org.freedesktop.Notifications.service.disabled

Finally restart your system to open a new session without notifications bubbles.

  • Didn't work (blah blah blah)
    – Empty
    May 14, 2014 at 23:41
  • sudo chmod -x /usr/lib/x86_64-linux-gnu/notify-osd doesn't work either :-( Jun 11, 2014 at 3:28
  • @Empty what is with the blah blah blah Dec 31, 2015 at 5:52
  • 2
    What I wanted to say was "Didn't work" but apparently that was too short so it was necessary to add something pointless to the end of it. blah blah blah seemed appropriately pointless. If you've got a better suggestion perhaps you can edit my comments and change "blah blah blah" to something else? All the best Trevor!
    – Empty
    Jan 1, 2016 at 8:40

Effectively disable notifications without messing with your system

A shamelessly ugly, but guaranteed perfectly working solution below. Although it is ugly, I can't see a real downside, and when no other options seem to exist or work, I believe we are excused.

The solution

From this nice answer, we learn that you can keep an eye on upcoming notifications. If we edit the command in that answer a bit, to simply kill the notification before it actually pops up, we effectively disable notifications. The set up:

  1. Create a small script with the following content:

    dbus-monitor "interface='org.freedesktop.Notifications'" | grep --line-buffered "string" | grep --line-buffered -e method -e ":" -e '""' -e urgency -e notify -v | grep --line-buffered '.*(?=string)|(?<=string).*' -oPi | grep --line-buffered -v '^\s*$' | xargs -I '{}' pkill notify-osd
  2. Save it as nonotifications.sh, and make it executable

  3. Test- run it by running in a terminal:


    (keep it running)

  4. If all works fine, add it to your Startup Applications. Choose Dash > Startup Applications > Add. Add the command:

    /bin/bash -c "sleep 15 && /path/to/nonotifications.sh"

Additional options

The fun part is that the solution can be connected to a script, as mentioned here, to (for example) only allow certain notifications, or only disable specific ones.

  • This actually works, and it is even a possibility to mute notifications temporarily (like during a meeting)
    – Graipher
    Feb 23, 2017 at 10:10

You can use Dconf Editor to disable the notifications. To install dconf editor, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install dconf-editor 

Once installed, type dconf in Dash, and then click on dconf Editor. Once open navigate to com --> canonical --> indicator --> and disable the ones you want.

enter image description here

  • 2
    I don't see anything under there for message bubbles?
    – Empty
    May 14, 2014 at 23:42
  • What message bubble are you referring to? Can you add and screen-shot?
    – Mitch
    May 15, 2014 at 5:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .