I have a huawei e303 u modem, I followed a guide from this link. Everything is working except calling features.

Call goes to other end but no voice OR vice versa.

I mean , when somebody calls me, it shows on the dashboard. When I receive, no sound from either end. I mean, balance deducts, timer shows call duration on dashboard. But no sound from either receiving or transmitting end.

2 Answers 2


This is how i made phone call from my Huawei modem K3772 on Ubuntu zesty using AT commands.Voice is working and i can also recieve call. I assume that your modem has voice capabilities and could make call on Mobile Partner in Windows

  1. insert your dongle into pc and should be detected by Network manager applet

2.Find out the various ports of the modem:

ls /dev/ttyU*

usually, the dialogue port (ie 1st port) is /dev/ttyUSB0, audio port (ie 2nd port) is /dev/ttyUSB1 and sms & internet aka data port (ie 3rd port) is /dev/ttyUSB3

  1. install picocom:

sudo apt install picocom

  1. start picocom on the dialogue port:

sudo picocom -c /dev/ttyUSB0

the -c means local echo on, making AT commands visible as you type

find the audio sample formats supported by your modem:


A reponse of 0,8000,16,10 means the rate is 8000hz

open another terminal and enable audio:

sudo cat /dev/ttyUSB1 | aplay -f S16_LE

open another terminal and enable microphone:

sudo arecord -f S16_LE /dev/ttyUSB1

the audio sampleformat, S16_LE is 'Signed 16 bit Little Endian', Rate 8000 Hz, Mono it depends on the response from AT^CVOICE? other modems may require S16_BE

go back to the first terminal and dial the number:


eg: ATD024698xxxx; OR ATD100;

from the same dialogue terminal he route audio:


you should now hear sound from your speakers and you can also speak into the mic

after you are done with your call, you can hangup with:


if you want to keep you modem online so you can recieve calls, then keep both terminals open You can recieve call with


followed by AT^DDSETEX=2 to enable sound
To stop picocom: ctrl+a followed by ctrl+x

The mmcli developers are trying to implement it in ModemManager.I think work is still on going. maybe modem-manager-gui might also implement voice someday

tIP:-if you hear scratcy sound instead of human voice, change S16_LE to S16_BE.This is the sample format. other sample formats can be gotten from aplay --help

reference: mmcli Huawei voice

  • This does almost work for me; the only thing, when reading audio from the modem, after a few kb the stream closes/ aborts. Also, I was not yet able to feed data correctly to the modem (I can, and I hear something on the other side, but just noises). Apr 21, 2018 at 18:51
  • using sudo arecord -f U8 -r 8000 -c 2 /dev/ttyUSB1 instead might get the sound a bit clearer
    – ptetteh227
    Mar 26, 2020 at 9:04

I have almost the same problem, using the e173 modem.

The sound most definitely works under windows 7.

the first answer, of course: wipe Ubuntu and install win7 - it just works.

(My setup is Fujitsu T580 4g i5 dual boot, Ubuntu 14.04 xubuntu 32bit Saga_of_Fail) 

The problem is exclusively the sound interface - it does not seem to exist.
In the source code there is no mention of whether this is still looking for ALSA or ?
The fact that the code is such a horribly mangled mess explains why they abandoned it.
Their later windows efforts abandon even trying to use voice calls.
lots of binary blobs come with the Mobile Partner along with barn-door sized
security holes like the sudoers edit 
ALL ALL=(ALL) NOPASSWD:ALL  (I kid you not, go look: /etc/sudoers
And there is also that autoupdate thingy which is doing what, precisely ?

The reality is:

Nobody (aside from you, me and handful of other strange personas)
in linux-land wants a simple modem dialer.
All other answers involve proprietary code (see talk.maemo.org for an earful)
and or other seriously rube-goldberg type solutions
If you doubt that just ask how Ubuntu-touch gets theirs - depressingly complicated !)

(I tried freeswitch and please don't even mention installing asterisk

just to make a simple audio phone call. I tried freeswitch. The code compiles, but...

(I had a serious nightmare after the freeswitch install, so very, very weird)

I think that the only other solution is to git the code for the python dialer
from the piphone project and rewrite it. To match your specific modem
 (as I am trying to do in my spare time)

Cheers, Let us know if you get it fixed some other way.

  • thanks for the answer, but there is not a single simple solution, Huawei is world's no.1 data card provider and modems are not still fully supported. Ubuntu's higher authorities may partner with them and in that way they can provide some way to do proper calling or they can remove bugs from it.
    – Kanhiya
    May 14, 2014 at 18:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .