12

Earlier when I run Ubuntu 12.04, It prompts to install printer on detecting by XTerm (It automatically download and configures hplip) and my hp-laserjet working fine on Ubuntu 12.04.

Now, I am running Ubuntu 14.04 (Installed form DVD). When I plugged printer, XTerm doesn't prompts so, I manually configured as following.


1. Open printer setting. It detects my Hp Laser Jet P1007

detect


2. It Auto configured correctly and ask to print test page

Describedtest-page


3. But It not prints test-page. Also not-printing anything and says job completed!

queue

Though It detected & configured properly but not printing.


Details from local-host:localhost


How to solve It?

  • Try looking at the cups web interface at localhost:631 and making sure your printer is the default printer and is enabled. – bain May 13 '14 at 12:47
  • @bain : I also added details from localhost:631. – Pandya May 13 '14 at 13:55
  • 1
    And this previously worked in 12.04 - exactly the same computer, printer, USB port etc.? Did you run hp-setup after installing 14.04? – bain May 13 '14 at 15:54
19

You need to run hp-setup after installing Ubuntu 14.04.

hp-setup Installs HPLIP printers and faxes in the CUPS spooler. Tries to automatically determine the correct PPD file to use. Allows the printing of a testpage. Performs basic fax parameter setup.

  • If I remember well, I tried to use hp-setup (amongst others) to get my HP LaserJet 1020 to reliably print in 14.04, but had to give up and buy an HP LaserJet Professional P1102, which works flawlessly. (In case someone wonders why I didn't buy the wireless model: because I don't like electromagnetic pollution.) – Walter Tross Oct 12 '14 at 13:29
  • 2
    You may need to run sudo apt-get install hplip-dbg hplip-gui before running hp-setup – mac Dec 1 '14 at 11:45
3

Run hp-setup, then if the problem still persists follow these steps, too:

  1. Go to http://localhost:631/, then go to "Printers", there your printer will be listed under queue name, click it.

  2. Click "Administration" drop down menu

  3. Select "set allowed users"

  4. Type in your computer "username" and "select allow these users to print" and click "Set allowed Users".

I successfully got the printer running using these steps in Ubuntu 14.04 LTS.

1

I had the same problem in Ubuntu 17.04 and Hp Laser Jet P1006 but neither installing by localhost:631 or setting "allowed users" nor using printers part of Ubuntu system tools helped me.
But I fixed the problem by removing printer in system tools > printers and running hp-setup -i that is an interface for "hplip".
By hp-setup -i setting up a new printer would be easy and without problem.
I added my new printer by using hp-setup -i steps and in final step it asked me for test print and then everything worked great.

0

All drivers with ljet4 sufix should work, you just have to find the right one. This should work for other printers too. In my company I had problems until I found out that few drivers works for all printer. I wrote large text about drivers solution here. I tried it on most of Ubuntu versions.

protected by Community Oct 7 '15 at 7:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.