I got a new keyboard with function keys, but I have to hold the FN key to use the F1|F12 keys normally and not to change the volume, brightness, etc. How do I change this?

  • Have you looked at other similar questions? askubuntu.com/q/170819/62483 & askubuntu.com/q/171166/62483 – Lucio May 12 '14 at 3:24
  • Hmmm... in my 3 keyboards the handling of "Fn" is totally hardware, and is invisible on the Linux side (I mean, I have to press Fn+keypad 0 to have "Menu", but xev see just the Menu keypress). So this thing should be a setting of the keyboard itself --- maybe a switch or a key combo --- or I fear it is basically impossible. Try with xev to see which key events are generated: wiki.archlinux.org/index.php/Extra_Keyboard_Keys. One of the keyboards has a "Fn lock" option. – Rmano May 12 '14 at 3:54
  • @Lucio; I have, and nothing (including those two) are what I'm looking for. – kookman98 May 12 '14 at 5:53
  • @Rmano; This is possible to change on windows, as many laptop keyboards require you to press FN in order to use the F keys normally. – kookman98 May 12 '14 at 5:54
  • If you can change it in Windows it could still be some proprietary magic sequence sent to the keyboard... Try to ask the vendor for Linux support, sometime it works... – Rmano May 12 '14 at 12:49