New install of 14.04 and I can't connect to a working wifi network ("Bricks and Scones" is the access point name in the log below). Other devices (eg. the android I'm using to post this) connect just fine. I'm not sure what's wrong with my configuration. I'm looking at syslog but still can't sort out what's going wrong. What do these warnings mean?

ryan@palms /v/log> tail -f syslog | grep -C5 'warn\|error'
May 11 18:55:18 palms avahi-daemon[730]: Withdrawing address record for 192.168.1.129 on wlan0.
May 11 18:55:18 palms avahi-daemon[730]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.129.
May 11 18:55:18 palms avahi-daemon[730]: Interface wlan0.IPv4 no longer relevant for mDNS.
May 11 18:55:09 palms whoopsie[1292]: online
May 11 18:55:18 palms whoopsie[1292]: offline
May 11 18:55:18 palms NetworkManager[985]: <warn> DNS: plugin dnsmasq update failed
May 11 18:55:18 palms wpa_supplicant[1004]: nl80211: Was expecting local disconnect but got another disconnect event first
May 11 18:55:18 palms dnsmasq[2269]: setting upstream servers from DBus
May 11 18:55:18 palms NetworkManager[985]: <info> Removing DNS information from /sbin/resolvconf
May 11 18:55:18 palms kernel: [  806.867681] cfg80211: Calling CRDA to update world regulatory domain
May 11 18:55:18 palms kernel: [  806.873484] cfg80211: World regulatory domain updated:
--
May 11 18:55:18 palms NetworkManager[985]: <info> Activation (wlan0) starting connection 'Bricks and Scones Guest Network'
May 11 18:55:18 palms NetworkManager[985]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
May 11 18:55:18 palms NetworkManager[985]: <info> NetworkManager state is now CONNECTING
May 11 18:55:18 palms NetworkManager[985]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
May 11 18:55:18 palms wpa_supplicant[1004]: wlan0: CTRL-EVENT-SCAN-STARTED 
May 11 18:55:18 palms NetworkManager[985]: <warn> Connection disconnected (reason -3)
May 11 18:55:18 palms NetworkManager[985]: <info> (wlan0): supplicant interface state: completed -> disconnected
May 11 18:55:18 palms NetworkManager[985]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
May 11 18:55:18 palms NetworkManager[985]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
May 11 18:55:18 palms NetworkManager[985]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
May 11 18:55:18 palms NetworkManager[985]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
--
May 11 18:55:39 palms NetworkManager[985]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) started...
May 11 18:55:39 palms NetworkManager[985]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
May 11 18:55:40 palms dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10 (xid=0x7609df84)
May 11 18:55:50 palms dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13 (xid=0x7609df84)
May 11 18:56:03 palms dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9 (xid=0x7609df84)
May 11 18:56:04 palms NetworkManager[985]: <warn> (wlan0): DHCPv4 request timed out.
May 11 18:56:04 palms NetworkManager[985]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 4231
May 11 18:56:04 palms NetworkManager[985]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
May 11 18:56:04 palms NetworkManager[985]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) started...
May 11 18:56:04 palms NetworkManager[985]: <info> (wlan0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
May 11 18:56:04 palms NetworkManager[985]: <info> NetworkManager state is now DISCONNECTED
May 11 18:56:04 palms NetworkManager[985]: <info> Marking connection 'Bricks and Scones Guest Network' invalid.
May 11 18:56:04 palms NetworkManager[985]: <warn> Activation (wlan0) failed for connection 'Bricks and Scones Guest Network'
May 11 18:56:04 palms NetworkManager[985]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
May 11 18:56:04 palms NetworkManager[985]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
May 11 18:56:04 palms NetworkManager[985]: <info> (wlan0): deactivating device (reason 'none') [0]
May 11 18:56:04 palms avahi-daemon[730]: Withdrawing address record for fe80::3623:87ff:fefd:5b57 on wlan0.
May 11 18:56:04 palms avahi-daemon[730]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::3623:87ff:fefd:5b57.
May 11 18:56:04 palms avahi-daemon[730]: Interface wlan0.IPv6 no longer relevant for mDNS.
May 11 18:56:04 palms wpa_supplicant[1004]: wlan0: CTRL-EVENT-DISCONNECTED bssid=7e:d1:c3:ce:2c:9a reason=3 locally_generated=1
May 11 18:56:04 palms NetworkManager[985]: <warn> Connection disconnected (reason -3)
May 11 18:56:04 palms wpa_supplicant[1004]: wlan0: CTRL-EVENT-SCAN-STARTED 
May 11 18:56:04 palms wpa_supplicant[1004]: nl80211: Was expecting local disconnect but got another disconnect event first
May 11 18:56:04 palms NetworkManager[985]: <info> (wlan0): supplicant interface state: completed -> disconnected
May 11 18:56:04 palms kernel: [  852.988624] cfg80211: Calling CRDA to update world regulatory domain
May 11 18:56:04 palms kernel: [  852.991920] cfg80211: World regulatory domain updated:

(longer one here: http://pastebin.com/EPbp51Dz )

  • Ever find a solution to this? Having a similar problem. – BryanK Sep 19 '15 at 19:50
  • I only saw it on one network that I don't use anymore – dranxo Sep 19 '15 at 20:58

Bit of a long shot, but your log has messages in common with one posted on the zeroset blog. His (and my) problem was that some adapters and access points interact badly in N mode. The workaround is to disable N mode and thus switch to a slower mode.

From your log it doesn't look like you have an Intel adapter, but if you do, you can try zeroset's solution:

Temporary solution

For a temporary solution, e.g. to check if the proposed solution helps for your setup, reload the iwlwifi kernel module with option 11n_disable set to 1, in order to disable 802.11N, e.g. by

sudo sh -c 'modprobe -r iwlwifi && modprobe iwlwifi 11n_disable=1'

You will be asked for your sudo password as you need root privilegues to reload a kernel module.

Permanent solution

For permanently disabling 802.11N in the driver, add the line

options iwlwifi 11n_disable=1

to /etc/modprobe.d/iwlwifi.conf

"Temporary" here means that it will revert once you restart.

sometimes you must first disable 802.11N like above, and then re-enable it again to fix the problem

I was having a similar problem, but no device could connect, even with ethernet. I'm putting my solution here, because this is the top google result for the error message.

I fixed this by turning the router off and turning it back on.

So for any smartasses like me, who start going through their logs to diagnose the problem, and see Connection disconnected (reason -3), and have not yet tried restarting the router... go do that before googling on.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.