4

OS: Lubuntu 14.04
Package: Xfce Power Manager
Package Settings:
- On AC > Actions > Put the computer to sleep when inactive for: 15 Minutes
- Extended > Set computer inactivity sleep mode: Hibernate
Intent: hibernate computer after 15 minutes of inactivity
Error message: not authorized
Error time: at hibernation

5

Follow the instructions for Ubuntu: How do I hibernate my computer?

That is, test first, then create a file /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla with the following content:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Note that in order to create this file you need root permissions. So, for instance, use sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

|improve this answer|||||
  • Sorry to hear that. However, this is a different problem with hibernation. See DebuggingKernelHibernate for how to debug this. Also, have a look whether others have had the same problem (and perhaps) already fixed for the device you are using. Eventually, you might want to report a bug against the kernel you are using. You might also want to check out TuxOnIce – xebeche May 27 '14 at 9:52
1

I had the same problem under xubuntu and it was due to light-locker which I believe is in use also under lubuntu. Reinstalling light locker fixed the problem permanently for me:

sudo aptitude purge light-locker light-locker-settings
sudo aptitude install light-locker light-locker-settings

I believe that removing and then re-installing fixed a policy problem somewhere.

|improve this answer|||||
0

For Lubuntu 14.04.1 I find /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla where was

[Disable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=no

[Disable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=no

Change ResultActive to yes for both blocks. If you don't find com.ubuntu.desktop.pkla - try to search any *.pkla file in /var/lib/polkit-1/localauthority folder for some same strings

|improve this answer|||||
  • @xebeche's answer above is better, as any changes under /var/lib/polkit-1 will be overwritten whenever the policykit-desktop-privileges package is upgraded. – Erik Forsberg Jan 5 '15 at 16:55
0

This is an old question, but just to point out something important, be careful when reinstalling light-locker and light-locker-settings because this action also removes lubuntu-desktop* which could be troublesome.

I would explore the polkit options first. Just chiming in.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy